Bug 842550 - During upgrade to Fedora 17 logical volumes (--mirrorlog mirrored) not handled properly
During upgrade to Fedora 17 logical volumes (--mirrorlog mirrored) not handle...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-24 03:35 EDT by Albert Flügel
Modified: 2012-08-03 16:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-03 16:37:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Albert Flügel 2012-07-24 03:35:23 EDT
Description of problem:
I have root and a data filesystem as lvm2 mirrored volumes with mirrorlog mode mirrored (lvmconvert --mirrorlog mirrored ...).
During boot after preupgrade anaconda throws an exception. Admittedly i did not save it unfortunately. However, i think it should be possible to find the respective piece of code. The message of the exception was: "Cannot modify /dev/mapper/vg_myhostname-lv_root_mlog directly". So it tried to modify the mirror log of the logical volume (why by the way ?!?), and failed. I guess it simply does not know how to handle mirrors with mirrorlog mode mirrored as this mode is relatively newly implemented.

Converting the volumes to mirrorlog type disk turned out to be a workaround for this.


Version-Release number of selected component (if applicable):
Frankly, i don't know and don't know how to determine. It's the anaconda in the stage2.img, that is installed by the preupgrade of Fedora 16 when instructed to upgrade to Fedora 17 "Beefy Miracle"

How reproducible:


Steps to Reproduce:
1. Install Fedora16
2. Make the root volume an lvm2 mirror
3. convert the mirror log to mode mirrored (lvmconvert --mirrorlog mirrored /dev/mapper/vg_myhostname-lv_root)
4. Install and run preupgrade requesting upgrade to Fedora 17
5. Reboot into the upgrade

Actual results:
Anaconda throws exception "Cannot modify /dev/mapper/vg... directly" (see above) and terminates.

Expected results:
Anaconda examines and mounts the logical volumes as they are and starts the upgrade


Additional info:
The problem can be workarounded booting back into the normal system and converting the volumes to mirrorlog type "disk" (lvconvert --mirrorlog disk ...)
Afterwards anaconda performs like expected. At least at this stage.
Comment 1 Jesse Keating 2012-07-24 13:10:08 EDT
Please attach all log files found in /tmp/*log during the installation when you run into the trouble.
Comment 2 Albert Flügel 2012-07-25 17:11:07 EDT
Tough luck, these files are empty :-(
So i'll try on my own. But i'll not go back to Fedora 16 and go through all this again, sorry. BTW i did a cross-architecture upgrade from i686 to x86_64 and ended up in a mess of a mixture of 32 and 64 bit packages, i was fixing manually. Annoying but i made it. Have a clean system now and will not jeopardise my consistent status.
Any hint, where to find the anaconda sources ?
Is it the anaconda-yum-plugins-...src.rpm ?
Comment 3 Albert Flügel 2012-08-03 16:37:33 EDT
i installed a virtual KVM/QEMU machine with 2 disks and Fedora 16, root as lvm2 mirror and mirrorlog mode mirrored like with my physical computer, to reproduce the problem.
Then i did preupgrade for Fedora 17 and booted and ... everything was working perfectly - it worked so well i could hardly believe. :-( or :-) !?!

Typical case of Vorführeffekt. (if interested please ask a translation machine what that means in English, i don't know).

So i close this thing now. Sorry for the efforts caused.

Note You need to log in before you can comment on or make changes to this bug.