Bug 842556 - Plymouth password login screen locks up after timeout
Plymouth password login screen locks up after timeout
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: plymouth (Show other bugs)
17
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-24 04:19 EDT by Björn Ruberg
Modified: 2012-09-03 08:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-03 08:04:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Björn Ruberg 2012-07-24 04:19:44 EDT
Description of problem:
I've seen this problem on four different systems since Fedora 15. I've encrypted my home partition and that's why plymouth prompts for a password on bootup.
I noted that I have to be fast to enter the password - because when I wait some minutes I can still enter the password, but nothing happens after that. The system just locks. I cannot leave plymouth by pressing ESC, all I can do is reboot. Very bad!

I tried it once with deactivating plymouth with ESC before the password prompt. And then I can actually see what happens. On the console I see a timeout message 
 of the password service and I'm advised to press Ctrl+D to go on. If I do that, I can enter the password again and everything is fine.

So the problem probably is, that the system expects you to press Ctrl+D, but you cannot see that from the password prompt. So there is no way of knowing that the solution is so simple.


Steps to Reproduce:
1. Have an encrypted partition
2. Boot your system and wait three minutes before entering the password
3. See nothing happending anymore.
  
Possible solutions:
1. Show the "press Strg+D" message in the plymouth prompt
2. Fall back to console if the password is not entered
Comment 1 Ray Strode [halfline] 2012-08-02 13:32:51 EDT
that sounds awful. Do you know if the message is coming from cryptsetup ?
Comment 2 Björn Ruberg 2012-09-03 08:04:38 EDT
Sorry, didn't geht the notification of your reply. 
I've seen my boxes falling back to console where you can see the "press Ctrl+D" message in the last days. Must have been an update. So I consider this specific bugs as closed.

But I see so many problems with this password-protected home devices that I have the feeling no one is using it. On boxes where I usually don't enter the password immediatly I've to restart in every second case because of sudden lockups in the startup process after inserting the password. Very weird.

Note You need to log in before you can comment on or make changes to this bug.