Bug 842734 - [RHEVM] [backend] [Host Networking] DC/CL 3.0 VLAN is offered multiple times
[RHEVM] [backend] [Host Networking] DC/CL 3.0 VLAN is offered multiple times
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
high Severity medium
: ---
: ---
Assigned To: Alona Kaplan
Martin Pavlik
network
: Regression
: 843856 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-24 09:38 EDT by Martin Pavlik
Modified: 2016-02-10 14:46 EST (History)
10 users (show)

See Also:
Fixed In Version: si13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:08:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (399.32 KB, application/x-gzip)
2012-07-24 09:38 EDT, Martin Pavlik
no flags Details
screenshot 1 (458.43 KB, image/jpeg)
2012-07-24 09:42 EDT, Martin Pavlik
no flags Details
screenshot 2 (206.47 KB, image/png)
2012-07-24 09:43 EDT, Martin Pavlik
no flags Details

  None (edit)
Description Martin Pavlik 2012-07-24 09:38:50 EDT
Created attachment 600027 [details]
logs

Description of problem:
For DC/CL 3.0 VLAN is offered to be connected to host NIC despite the fact it is already connected to the interface (see screenshot 1)

In case user selects the VLAN to be connected second time, error message which does not make much sense appears: (see screenshot 2)

Error:

dell-05:

    Previous network name is required.



Version-Release number of selected component (if applicable):
oVirt Engine Version: '3.1.0-7.el6ev' 

How reproducible:
100%

Steps to Reproduce:
1.create multiple VLANs and attach it to cluster 3.0
2.Hosts -> your host -> Network Interfaces -> some free NIC -> Add/Edit -> assign VLAN
3.Hosts -> your host -> Network Interfaces -> some free NIC -> Add/Edit -> observe drop down menu for Network: (screenshot 1) -> Pick same VLAN as in step 2 (screenshot 2)

  
Actual results:
1) VLAN is offered to be connected to host NIC despite the fact it is already connected

Expected results:
1) VLAN should not be offered if already connected to the NIC

Additional info:

engine.log
2012-07-24 15:25:33,603 WARN  [org.ovirt.engine.core.bll.UpdateNetworkToVdsInterfaceCommand] (ajp-/0.0.0.0:8009-11) [c04b26e] CanDoAction of action UpdateNetworkToVdsInterface failed. Reasons:NETWROK_OLD_NETWORK_NOT_SPECIFIED
Comment 1 Martin Pavlik 2012-07-24 09:42:45 EDT
Created attachment 600030 [details]
screenshot 1
Comment 2 Martin Pavlik 2012-07-24 09:43:04 EDT
Created attachment 600031 [details]
screenshot 2
Comment 4 Alona Kaplan 2012-07-29 03:45:50 EDT
fixeed in commit e8984e444707891102808adc6df03e8b7dc5f39a
Comment 5 lpeer 2012-08-15 04:48:29 EDT
*** Bug 843856 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.