Bug 842744 - jfreechart is missing OSGi metadata
jfreechart is missing OSGi metadata
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: jfreechart (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-24 09:59 EDT by Severin Gehwolf
Modified: 2012-09-17 07:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-31 09:08:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch with a proposed fix (1.94 KB, patch)
2012-07-24 09:59 EDT, Severin Gehwolf
no flags Details | Diff

  None (edit)
Description Severin Gehwolf 2012-07-24 09:59:02 EDT
Created attachment 600034 [details]
Patch with a proposed fix

Description of problem:
Generated jars don't have OSGi metadata and can not be used as a dependency for Eclipse plug-ins

Version-Release number of selected component (if applicable):
1.0.14-1

I'm attaching a patch which fixes this.
Comment 1 Severin Gehwolf 2012-07-24 10:00:29 EDT
If you prefer that I push the fix you could approve the requested commit privs (jerboaa) and I'll push the fix. Thanks!
Comment 2 Severin Gehwolf 2012-08-31 09:08:38 EDT
This has been fixed with http://koji.fedoraproject.org/koji/buildinfo?buildID=346940
Comment 3 Lubomir Rintel 2012-09-17 07:32:19 EDT
Thanks a lot!

I've approved your ACLs and remove myself from package, since I'm no longer willing to deal with Java stuff. I'd be thankful if you could take the package.

Note You need to log in before you can comment on or make changes to this bug.