Bug 842772 - quotacheck is broken with gfs2
quotacheck is broken with gfs2
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: quota (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Abhijith Das
qe-baseos-daemons
:
Depends On:
Blocks: 846120
  Show dependency treegraph
 
Reported: 2012-07-24 10:55 EDT by Abhijith Das
Modified: 2012-08-06 17:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 846120 (view as bug list)
Environment:
Last Closed: 2012-07-25 16:38:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Abhijith Das 2012-07-24 10:55:34 EDT
Description of problem:
With recent rhel6 bits, (kernel-2.6.32-279.el6.x86_64, quota-3.17-16.el6.x86_64) quotacheck fails with the following message:

[root@smoke-01 ~]# quotacheck -c -v -u /tmp/tmp.rOhWilMkyT/tmp.BLFbVAKjMr/
quotacheck: Scanning /dev/loop0 [/tmp/tmp.rOhWilMkyT/tmp.BLFbVAKjMr] done
quotacheck: Cannot stat old user quota file: No such file or directory
quotacheck: Old group file not found. Usage will not be substracted.
quotacheck: Checked 2 directories and 0 files

This problem is also upstream and in rhel7.
Comment 2 Abhijith Das 2012-07-25 16:38:37 EDT
Upon further testing, it looks like these messages are debug messages that show up with -v. While they don't apply to gfs2 and should probably be cleaned up so as to not confuse the user, quotacheck actually works properly. When used w/o the -v option, it silently updates the quota file with any changes.

Note You need to log in before you can comment on or make changes to this bug.