Bug 842845 - parsing a non-numeric port number from the --baseurl option
parsing a non-numeric port number from the --baseurl option
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Adrian Likins
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-07-24 13:46 EDT by John Sefler
Modified: 2013-01-07 22:57 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:57:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-07-24 13:46:11 EDT
Description of problem:
When a user specifies a value for the --baseurl, there is a parsing alogrithm that tries to decompose the host, port, and prefix.  The value parsed for the port should probably check for an integer.


Version-Release number of selected component (if applicable):
[root@jsefler-rhel59 ~]# rpm -q subscription-manager
subscription-manager-1.0.9-1.git.37.53fde9a.el5


How reproducible:


Steps to Reproduce:
[root@jsefler-rhel59 ~]# subscription-manager register --username testuser1 --password password --org admin --force --baseurl=https://myhost:/myapp
Error parsing baseurl: Server url port could not be parsed

[root@jsefler-rhel59 ~]# subscription-manager register --username testuser1 --password password --org admin --force --baseurl=https://myhost:PORT/myapp
The system with UUID 428db7e2-2e59-406d-bc30-bfd30311395d has been unregistered
The system has been registered with id: 988269f1-0834-4474-8c18-d245596fa3f5 

^^^
EXPECTED Error parsing baseurl: Server url port should be numeric
Comment 1 RHEL Product and Program Management 2012-07-24 13:58:24 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Adrian Likins 2012-08-01 17:50:51 EDT
commit a90e0894655dfa88c7e864777eeb628df7422922
Author: Adrian Likins <alikins@redhat.com>
Date:   Wed Aug 1 17:47:54 2012 -0400

    842845: Show better error if serverurl port is non numeric

(patch out for review)
Comment 3 Adrian Likins 2012-08-02 11:25:55 EDT
merged to master
Comment 5 Sharath Dwaral 2012-08-03 11:24:07 EDT
Version:

# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-migration-1.0.12-1.git.6.1cb2247.el5
subscription-manager-1.0.12-1.git.6.1cb2247.el5
subscription-manager-firstboot-1.0.12-1.git.6.1cb2247.el5
python-rhsm-1.0.4-1.git.7.47e5112.el5
subscription-manager-migration-data-1.11.2.2-1.git.2.c3c8e22.el5
subscription-manager-gui-1.0.12-1.git.6.1cb2247.el5


Verification:

# subscription-manager register --username testuser1 --password password --org admin --force --baseurl=https://myhost:PORT/myapp
Error parsing baseurl: Server url port should be numeric

Moving Bug to VERIFIED
Comment 7 errata-xmlrpc 2013-01-07 22:57:41 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.