Bug 842860 - Wrong error message when deleting admin user
Wrong error message when deleting admin user
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
2.0.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: Sprint 39
Assigned To: Sayli Karmarkar
Preethi Thomas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-24 14:22 EDT by Preethi Thomas
Modified: 2015-03-22 21:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-09 12:07:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2012-07-24 14:22:54 EDT
Description of problem:

The error message says The values for the following properties were invalid: login when deleting the admin user.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Try to delete a user adming
2.
3.
  
Actual results:

[root@pulp-f16 ~]# pulp-admin user delete --login admin
The values for the following properties were invalid: login

[root@pulp-f16 ~]# 

Expected results:


Additional info:

From the log

2012-07-24 14:17:04,157 13584:140275529664256: pulp.server.dispatch.task:ERROR: task:133 Invalid properties: ['login']
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/pulp/server/dispatch/task.py", line 130, in _run
    result = call(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/pulp/server/managers/auth/user.py", line 109, in delete_user
    raise InvalidValue(['login'])
InvalidValue: Invalid properties: ['login']
2012-07-24 14:17:04,159 13584:140275529664256: pulp.server.dispatch.task:INFO: task:163 Task c529a13a-d5bb-11e1-a17e-5452007c4f00: CallRequest: UserManager.delete_user(u'admin') FAILED
Comment 1 Sayli Karmarkar 2012-07-24 16:50:23 EDT
Fixed.

$ pulp-admin user delete --login admin
The server indicated one or more values were incorrect. The server provided the
following error message:

   The last superuser [500f057fe5e710624a000009] cannot be deleted

More information can be found in the client log file ~/.pulp/admin.log.
Comment 2 Sayli Karmarkar 2012-07-26 17:33:59 EDT
Needed to revert this commit since there are a few more auth-refactor changes that need to go in, in order for it to work correctly. It is fixed in sayli-auth-refactor branch which will be merged in master soon. I will confirm and move it to modified at that time.
Comment 3 Sayli Karmarkar 2012-08-21 15:03:58 EDT
Fixed after merging auth-refactor branch. Moving to modified.

$ pulp-admin user delete --login admin
The server indicated one or more values were incorrect. The server provided the
following error message:

   The last superuser [admin] cannot be deleted

More information can be found in the client log file ~/.pulp/admin.log.
Comment 4 Sayli Karmarkar 2012-08-21 15:04:38 EDT
Moving to on_qa as this is already in latest build.
Comment 5 Preethi Thomas 2012-09-11 09:40:26 EDT
verified
[root@preethi-el6-pulp ~]# rpm -q pulp-rpm-server
pulp-rpm-server-2.0.3-1.el6.noarch
[root@preethi-el6-pulp ~]# pulp-admin user delete --login admin
The server indicated one or more values were incorrect. The server provided the
following error message:

   The last superuser [admin] cannot be deleted

More information can be found in the client log file ~/.pulp/admin.log.

[root@preethi-el6-pulp ~]#
Comment 6 Preethi Thomas 2013-01-09 12:07:13 EST
Pulp v2.0 released

Note You need to log in before you can comment on or make changes to this bug.