Bug 842883 - Echo commands in kickstart snippets to assist debugging
Echo commands in kickstart snippets to assist debugging
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: scheduler (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 0.9.4
: ---
Assigned To: Dan Callaghan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-24 16:16 EDT by Steven Lawrance
Modified: 2012-10-11 19:50 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-11 19:50:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Lawrance 2012-07-24 16:16:22 EDT
Having -v or -x set in %pre and %post snippets could make tracking down various failures much easier when trawling through console logs.  As it is, it can be a little difficult to line up command output with the contents of the kickstart, especially because large segments of the snippets produce no output.

The additional noise in the console logs should not be significant considering how large they get as it is.
Comment 1 Dan Callaghan 2012-09-04 21:30:53 EDT
On Gerrit: http://gerrit.beaker-project.org/1318
Comment 3 Dan Callaghan 2012-10-11 19:50:08 EDT
Beaker 0.9.4 has been released.

Note You need to log in before you can comment on or make changes to this bug.