Bug 842972 - ldc does not compile simple hello world script
ldc does not compile simple hello world script
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: ldc (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: MERCIER Jonathan
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 843773
  Show dependency treegraph
 
Reported: 2012-07-25 03:43 EDT by Pierre-YvesChibon
Modified: 2012-11-14 11:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-14 11:07:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierre-YvesChibon 2012-07-25 03:43:32 EDT
Description of problem:
I retrieved a simple helloworld program from http://prowiki.org/wiki4d/wiki.cgi?D__Tutorial/StartingWithD

$ cat helloworld.d 
/*
 * Dependencies:
 *   ldc ldc-phobos
 * Compile with:
 *   ldc2 read_fasta.d
 */

import std.stdio;

int main()
{
    writefln("%s World!", "Hello");
    return 0;
}

$ ldc2 helloworld.d 
/usr/include/d/std/stdio.d(18): Error: module stdio is in file 'core/stdc/stdio.d' which cannot be read
import path[0] = /builddir/build/BUILD/ldc-20110901git58d40d2/runtime/../import
import path[1] = /usr/include/d
import path[2] = /builddir/build/BUILD/ldc-20110901git58d40d2/druntime/import
import path[3] = /builddir/build/BUILD/ldc-20110901git58d40d2/druntime/src
import path[4] = /builddir/build/BUILD/ldc-20110901git58d40d2/phobos/


Version-Release number of selected component (if applicable):
$ rpm -qa ldc\*
ldc-phobos-2-4.20110801git58d40d2.fc16.x86_64
ldc-2-4.20110801git58d40d2.fc16.x86_64
ldc-druntime-2-4.20110801git58d40d2.fc16.x86_64
ldc-phobos-devel-2-4.20110801git58d40d2.fc16.x86_64
ldc-druntime-devel-2-4.20110801git58d40d2.fc16.x86_64


How reproducible:
always

Steps to Reproduce:
1. Create the above helloworld.d file
2. Try to compile it with ldc2
3. Watch it fail
  
Actual results:
Presented above (fails)

Expected results:
A binary

Additional info:
Comment 1 MERCIER Jonathan 2012-07-27 08:59:33 EDT
ok The main problem it is:
- I can't upgrade ldc because fedora 16 provide llvm 2.9 and nt greater
- I cant rebuild a package to fix it because i got a gcc regression: #843773

I am really sorry for this bug I try to fix it.

Only thing i can said ldc works well with f17 and rawhide f18.

Thanks to understanding

Note You need to log in before you can comment on or make changes to this bug.