Bug 843031 - RFE: Make --fetch-pubsnum the default for publish
RFE: Make --fetch-pubsnum the default for publish
Status: CLOSED WONTFIX
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Lee Newson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-25 07:34 EDT by Joshua Wulf
Modified: 2014-10-19 19:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-20 05:53:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2012-07-25 07:34:49 EDT
Rationale:

1. Fetching the latest pubsnumber can never result in a wrong outcome.
2. 99% of the time it will in fact actively save the author from the hell of manually syncing pubsnumbers.
3. The overhead of fetching the latest pubsnumber as a percentage of the whole process is a micro portion of 1% (downloading topics, pushing to brew etc...).
4. Typing --fetch-pubsnum every time is 80% more work.
Comment 1 Lee Newson 2012-07-27 03:18:58 EDT
Point one is incorrect actually, if the --fetch-pubsnum is specified then it will fail if the URL doesn't exist. Other then that the only argument I have against it is that not all builds might be published using brew.

It was for those two reasons that I didn't make it the default in the first place (as I've mentioned in Bug #829947 already). Anyways I'll re-evaluate it and talk it over and get back to this RFE.
Comment 2 Lee Newson 2012-09-20 05:53:14 EDT
Since the pubsnumber is no longer valid in Publican 3, this functionality is no longer usable and therefore would be a waste of time. So I'm marking this as closed.

Note You need to log in before you can comment on or make changes to this bug.