Bug 843057 - RHEVM - Backend: Discover Targets sometimes returns empty list
RHEVM - Backend: Discover Targets sometimes returns empty list
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
Unspecified Unspecified
high Severity high
: ---
: 3.1.0
Assigned To: Daniel Erez
Leonid Natapov
storage
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-25 09:10 EDT by Daniel Paikov
Modified: 2016-02-10 11:36 EST (History)
12 users (show)

See Also:
Fixed In Version: SI14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:07:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm.log (924.51 KB, application/x-compressed-tar)
2012-07-25 09:10 EDT, Daniel Paikov
no flags Details
engine.log (122.94 KB, application/x-compressed-tar)
2012-07-25 09:10 EDT, Daniel Paikov
no flags Details

  None (edit)
Description Daniel Paikov 2012-07-25 09:10:06 EDT
Created attachment 600294 [details]
vdsm.log

Discover Targets via the GUI sometimes returns an empty list. Clicking on Discover again refreshes the list and populates it this time.

Logs include a failed Discover Targets (one before last) and then a successful Discover Targets (last).
Comment 1 Daniel Paikov 2012-07-25 09:10:37 EDT
Created attachment 600295 [details]
engine.log
Comment 2 Haim 2012-07-25 10:26:36 EDT
from looking at the logs, It looks like admin-portal refresh issue and not engine, since on both attempts, it appears that engine returns list of targets, so it's a UI problem, what do you think?
Comment 3 Daniel Erez 2012-07-29 14:52:25 EDT
Looks like a refresh problem indeed - moving to webadmin component.
Comment 4 Daniel Erez 2012-07-29 15:30:37 EDT
http://gerrit.ovirt.org/#/c/6702/
Comment 7 Daniel Erez 2012-08-01 10:11:49 EDT
commit fb361b958071a5d8b93350c385e3856a51ffcb51
Comment 10 Leonid Natapov 2012-08-16 10:10:50 EDT
si14. Didn't succeed to reproduce. Tried several times with several ISCSI domains.

Note You need to log in before you can comment on or make changes to this bug.