Bug 843166 - Software Update Failed
Software Update Failed
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-25 14:59 EDT by ChadN
Modified: 2014-01-21 18:23 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-26 01:16:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ChadN 2012-07-25 14:59:42 EDT
Description of problem:
Updated from Fedora 15 to Fedora 17 without error a month ago. Have done updates since then, but recently, the udpate has failed with the following message:

ERROR with transaction check vs depsolve:
kernel-uname-r = 2.6.43.2-6.fc15.i686.PAE is needed by kmod-nvidia-2.6.43.2-6.fc15.i686.PAE-1:280.13-4.fc15.3.i686
kernel-uname-r = 2.6.43.5-2.fc15.i686.PAE is needed by kmod-nvidia-2.6.43.5-2.fc15.i686.PAE-1:280.13-4.fc15.5.i686
kernel-uname-r = 2.6.43.8-1.fc15.i686.PAE is needed by kmod-nvidia-2.6.43.8-1.fc15.i686.PAE-1:280.13-4.fc15.6.i686
kernel-uname-r = 2.6.43.2-6.fc15.i686.PAE is needed by kmod-nvidia-2.6.43.2-6.fc15.i686.PAE-1:280.13-4.fc15.3.i686
kernel-uname-r = 2.6.43.5-2.fc15.i686.PAE is needed by kmod-nvidia-2.6.43.5-2.fc15.i686.PAE-1:280.13-4.fc15.5.i686
kernel-uname-r = 2.6.43.8-1.fc15.i686.PAE is needed by kmod-nvidia-2.6.43.8-1.fc15.i686.PAE-1:280.13-4.fc15.6.i686
Please report this error at https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum


Version-Release number of selected component (if applicable):
Looks like version 15, but I have 17 installed.


How reproducible:
Every time I attempt to update.


Steps to Reproduce:
1. Open Software Update application
2. Leave everything checked (127 updates selected).
3. Click Install Updates
  
Actual results:
Gets list, resolves dependencies, downloads packages, tests changes -> dialog appears with error message above.


Expected results:
Expect all updates to succeed.


Additional info:
None.
Comment 1 Tim Lauridsen 2012-07-26 01:16:48 EDT
Look like a problem with old nvidia kernel module, where the kernel is no longer installed.

do a 

rpm -qa kmod-nvidia*

and remove the F15 ones with 

rpm -e <full kmod package name>
Comment 2 ChadN 2012-07-26 09:16:36 EDT
Thanks. That looks like it solved the problem.

Any idea why the F15 ones were not removed when I upgraded to F17?

Note You need to log in before you can comment on or make changes to this bug.