Bug 843181 - temporary-administrative-user-xxx remains after aeolus-configure
temporary-administrative-user-xxx remains after aeolus-configure
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-configure (Show other bugs)
1.0.0
x86_64 Linux
unspecified Severity low
: rc
: ---
Assigned To: John Eckersberg
Giulio Fidente
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-25 15:40 EDT by Aaron Weitekamp
Modified: 2012-12-04 10:15 EST (History)
4 users (show)

See Also:
Fixed In Version: aeolus-configure-2.8.2-1.el6cf
Doc Type: Bug Fix
Doc Text:
aeolus-configure-2.5.x would occasionally leave a temporary administrative user in the Cloud Engine database. This update removes the temporary user.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:15:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
aeolus-configure.log (12.39 KB, text/x-log)
2012-07-25 15:40 EDT, Aaron Weitekamp
no flags Details
ui_screencap (131.47 KB, image/png)
2012-07-25 15:43 EDT, Aaron Weitekamp
no flags Details

  None (edit)
Description Aaron Weitekamp 2012-07-25 15:40:54 EDT
Created attachment 600386 [details]
aeolus-configure.log

Description of problem:
temporary-administrative-user-392fa7d4f8d775b1e8594e7274a620799fb935c7fe63e0a7 remains after aeolus-configure -p ec2

Destroy_temp_admin fails due to dependency failure
* Related to BZ-843117

Version-1.0.1 (from puddle):
# rpm -qa|grep aeolus
aeolus-conductor-doc-0.8.34-1.el6cf.noarch
aeolus-all-0.8.34-1.el6cf.noarch
aeolus-conductor-0.8.34-1.el6cf.noarch
aeolus-configure-2.5.10-1.el6cf.noarch
rubygem-aeolus-cli-0.3.3-2.el6_2.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-daemons-0.8.34-1.el6cf.noarch


Steps to Reproduce:
# aeolus-configure -p ec2 (without 'mock')


Expected results:
expect to see single admin user defined. Temp user is confusing and clutters UI
Comment 1 Aaron Weitekamp 2012-07-25 15:43:04 EDT
Created attachment 600387 [details]
ui_screencap
Comment 3 Giulio Fidente 2012-09-25 12:06:05 EDT
works as expected with aeolus-configure-2.8.7-1.el6cf
Comment 5 errata-xmlrpc 2012-12-04 10:15:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.