Bug 843313 - Community site can not be accessed in devenv.
Community site can not be accessed in devenv.
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-25 23:12 EDT by Yujie Zhang
Modified: 2015-05-14 21:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-07 16:42:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot1 (133.02 KB, image/png)
2012-07-25 23:12 EDT, Yujie Zhang
no flags Details
error_log (41.42 KB, text/plain)
2012-07-25 23:40 EDT, Xiaoli Tian
no flags Details

  None (edit)
Description Yujie Zhang 2012-07-25 23:12:00 EDT
Created attachment 600425 [details]
screenshot1

Description of problem:
When I tried to access the openshift website, I found the home page is mess and all the other pages are not accessible.

Version-Release number of selected component (if applicable):

devenv_1912

How reproducible:always


Steps to Reproduce:
1.Go to openshift website.
2.
3.
  
Actual results:

The website is not accessible.Details see in attachment.

Expected results:

The website should be accessible and correct.

Additional info:
Comment 1 Xiaoli Tian 2012-07-25 23:40:01 EDT
Created attachment 600432 [details]
error_log

It maybe caused by some Selinux policy changes, error log in httpd/error_log: attached is the whole log. 

[Wed Jul 25 17:34:13 2012] [notice] SELinux policy enabled; httpd running as context unconfined_u:system_r:httpd_t:s0
[Wed Jul 25 17:34:13 2012] [error] (2)No such file or directory: mod_mime_magic: can't read magic file /var/www/stickshift/site/httpd/conf/magic
[Wed Jul 25 17:34:16 2012] [error] (2)No such file or directory: mod_mime_magic: can't read magic file /var/www/stickshift/site/httpd/conf/magic
[Wed Jul 25 17:34:16 2012] [notice] Apache/2.2.15 (Unix) Phusion_Passenger/3.0.4 configured -- resuming normal operations
Rails Error: Unable to access log file. Please ensure that /var/www/stickshift/site/log/development.log exists and is chmod 0666. The log level has been raised to WARN and the output directed to STDERR until the problem is fixed.
DEPRECATION WARNING: config.action_view.debug_rjs will be removed in 3.1, from 3.1 onwards you will need to install prototype-rails to continue to use RJS templates . (called from /var/www/stickshift/site/config/environment.rb:5)
Rails Error: Unable to access log file. Please ensure that /var/www/stickshift/site/log/development.log exists and is chmod 0666. The log level has been raised to WARN and the output directed to STDERR until the problem is fixed.
[ pid=761 thr=140684642645792 file=ext/common/Watchdog.cpp:857 time=2012-07-25 17:34:46.276 ]: Some Phusion Passenger agent processes did not exit in time, forcefully shutting down all.
DEPRECATION WARNING: config.action_view.debug_rjs will be removed in 3.1, from 3.1 onwards you will need to install prototype-rails to continue to use RJS templates . (called from /var/www/stickshift/site/config/environment.rb:5)
> No session 
> No session 
> No session 
[Wed Jul 25 17:38:04 2012] [notice] caught SIGTERM, shutting down
[Wed Jul 25 22:15:25 2012] [notice] SELinux policy enabled; httpd running as context system_u:system_r:httpd_t:s0
[Wed Jul 25 22:15:25 2012] [error] (2)No such file or directory: mod_mime_magic: can't read magic file /var/www/stickshift/site/httpd/conf/magic
[Wed Jul 25 22:15:25 2012] [error] (2)No such file or directory: mod_mime_magic: can't read magic file /var/www/stickshift/site/httpd/conf/magic
[Wed Jul 25 22:15:25 2012] [notice] Apache/2.2.15 (Unix) Phusion_Passenger/3.0.4 configured -- resuming normal operations
[ pid=1518 thr=140516296345376 file=ext/common/Watchdog.cpp:857 time=2012-07-25 22:15:55.386 ]: Some Phusion Passenger agent processes did not exit in time, forcefully shutting down all.
[Wed Jul 25 22:40:01 2012] [error] [client 127.0.0.1] (13)Permission denied: access to /app/stylesheets/overpass.css denied, referer: https://ec2-23-20-177-219.compute-1.amazonaws.com/app
[Wed Jul 25 22:40:01 2012] [error] [client 127.0.0.1] (13)Permission denied: access to /app/javascripts/modernizr.min.js denied, referer: https://ec2-23-20-177-219.compute-1.amazonaws.com/app
[Wed Jul 25 22:40:01 2012] [error] [client 127.0.0.1] (13)Permission denied: access to /app/javascripts/rails.js denied, referer: https://ec2-23-20-177-219.compute-1.amazonaws.com/app
[Wed Jul 25 22:40:01 2012] [error] [client 127.0.0.1] (13)Permission denied: access to /app/javascripts/plugins.js denied, referer: https://ec2-23-20-177-219.compute-1.amazonaws.com/app
[Wed Jul 25 22:40:02 2012] [error] [client 127.0.0.1] (13)Permission denied: access to /app/images/time.png denied, referer: https://ec2-23-20-177-219.compute-1.amazonaws.com/app
[Wed Jul 25 22:40:02 2012] [error] [client 127.0.0.1] (13)Permission denied: access to /app/stylesheets/site.css denied, referer: https://ec2-23-20-177-219.compute-1.amazonaws.com/app
[Wed Jul 25 22:40:02 2012] [error] [client 127.0.0.1] (13)Permission denied: access to /app/javascripts/jquery.cookie.js denied, referer: https://ec2-23-20-177-219.compute-1.amazonaws.com/app
[Wed Jul 25 22:40:02 2012] [error] [client 127.0.0.1] (13)Permission denied: access to /app/images/scale.png denied, referer: https://ec2-23-20-177-219.compute-1.amazonaws.com/app
[Wed Jul 25 22:40:02 2012] [error] [client 127.0.0.1] (13)Permission denied: access to /app/stylesheets/common.css denied, referer: https://ec2-23-20-177-219.compute-1.amazonaws.com/app
[Wed Jul 25 22:40:02 2012] [error] [client 127.0.0.1] (13)Permission denied: access to /app/javascripts/bootstrap-dropdown.js denied, referer: https://ec2-23-20-177-219.compute-1.amazonaws.com/app
[Wed Jul 25 22:40:02 2012] [error] [client 127.0.0.1] (13)Permission denied: access to /app/javascripts/jquery.validate.min.js denied, referer: https://ec2-23-20-177-219.compute-1.amazonaws.com/app
[Wed Jul 25 22:40:02 2012] [error] [client 127.0.0.1] (13)Permission denied: access to /app/javascripts/twitter.branding.js denied, referer: https://ec2-23-20-177-219.compute-1.amazonaws.com/app
[Wed Jul 25 22:40:02 2012] [error] [client 127.0.0.1] (13)Permission denied: access to /app/javascripts/form.js denied, referer: https://ec2-23-20-177-219.compute-1.amazonaws.com/app
[Wed Jul 25 22:40:02 2012] [error] [client 127.0.0.1] (13)Permission denied: access to /app/javascripts/home.branding.js denied, referer: https://ec2-23-20-177-219.compute-1.amazonaws.com/app
Comment 2 Yujie Zhang 2012-07-27 04:07:42 EDT
The community is still not available on devenv_1916, since the other parts are available now, lower the severity.
Comment 3 Clayton Coleman 2012-07-30 00:13:36 EDT
Anderson can you help investigate this?
Comment 4 Anderson Silva 2012-07-30 08:07:09 EDT
Clayton, the mysql import is dying because I think the amount of data being imported is increasing...

I think you if you add:

max_allowed_packet=16384000

To the /etc/my.cnf

The import will be successful, and things should go back to normal.
Comment 5 Clayton Coleman 2012-07-30 10:03:42 EDT
It was max allowed packet.  I bumped it to 100M
Comment 6 Yujie Zhang 2012-07-30 22:50:26 EDT
(In reply to comment #5)
Tested this issue on devenv_1922, the community can be accessed now, thanks.

Note You need to log in before you can comment on or make changes to this bug.