Bug 843315 - user requests support for 'whois'
user requests support for 'whois'
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Rob Millner
libra bugs
:
: 847834 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-25 23:25 EDT by Nam Duong
Modified: 2015-05-14 22:01 EDT (History)
6 users (show)

See Also:
Fixed In Version: libra_ami #2017
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 17:29:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nam Duong 2012-07-25 23:25:25 EDT
Description of problem:

As per https://openshift.redhat.com/community/forums/openshift/enable-whois-command-on-the-server, user is requesting 'whois' cmd enabled/installed on the platform.
Comment 1 Mike Khusid 2012-07-26 00:03:08 EDT
Replied in the thread. This may be a limited use case.
Comment 2 Rob Millner 2012-08-14 13:08:39 EDT
This is an SELinux restriction, taking it.
Comment 3 Rob Millner 2012-08-14 13:09:25 EDT
*** Bug 847834 has been marked as a duplicate of this bug. ***
Comment 4 Rob Millner 2012-08-16 15:30:25 EDT
Commit 2a057163 adds support for contacting whois servers in the selinux policy.
Comment 5 Rob Millner 2012-08-16 18:04:56 EDT
Pull request:
https://github.com/openshift/li/pull/252
Comment 6 Rob Millner 2012-08-17 13:21:30 EDT
Pull request merged.
Comment 7 joycezhang 2012-08-20 03:53:57 EDT
This bug has been verified and fixed. 

Please refer to the details as below:

Build:
rhc.0.97.12.gem
devenv_2029

Verified steps:
1. Create an ruby app
#rhc app create -a ruby19 -t ruby-1.9 -p redhat
2.SSH into the app and check the port 43 status:
[ruby19-joycedev2.dev.rhcloud.com ~]\> irb 
irb(main):001:0> require "socket" 
=> true 
irb(main):002:0> socket = TCPSocket.new("whois.nic.it", 43) 
=> #<TCPSocket:fd 5> 
irb(main):003:0> socket.write ("example.it\r\n") 
=> 12 
irb(main):004:0> response = socket.read 
=> "" 
irb(main):005:0> puts response 

=> nil 

The port 43 is opened be default. 

So mart it as verified. Thanks.

Note You need to log in before you can comment on or make changes to this bug.