This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 843325 - [virtio-win][balloon]Guest memory can not continue evicting after enable balloon driver
[virtio-win][balloon]Guest memory can not continue evicting after enable ball...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.4
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-25 23:35 EDT by dawu
Modified: 2013-02-21 05:40 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:40:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description dawu 2012-07-25 23:35:18 EDT
Description of problem:
During evict guest memory, disable balloon driver, memory will change back to original, enable balloon driver again,guest memory can not continue evicting any more, it keeps the original value.

Version-Release number of selected component (if applicable):
kernel-2.6.32-279.el6.x86_64
qemu-kvm-0.12.1.2-2.295.el6.x86_64
virtio-win-prewhql-30

How reproducible:
always

Steps to Reproduce:
1.Start guest with CLI:
  /usr/libexec/qemu-kvm -m 7G -smp 3 -cpu Penryn,+x2apic -usb -device usb-tablet -drive file=win2k8-64.qcow2,format=qcow2,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -netdev tap,id=hostnet0,script=/etc/qemu-ifup0 -device e1000,netdev=hostnet0,mac=00:10:16:23:11:25,bus=pci.0,addr=0x4 -uuid ee19a2c1-ecf0-4073-bcf0-08304313f391 -rtc base=localtime -no-kvm-pit-reinjection -monitor stdio -name win2k8-64-fun -vnc :1 -bios /usr/share/seabios/bios-pm.bin -device virtio-balloon-pci,addr=0x6,bus=pci.0 -chardev socket,id=111a,path=/tmp/monitor-win2k8-64-balloon-30,server,nowait -mon chardev=111a,mode=readline

2.Evict guest memory to 1024
  (qemu) balloon 1024

3.Disable balloon driver during evicting by right click "VirtIO balloon Driver"--->disable
  
4.Info balloon, guest memory changes back to original value

5.Enable balloon driver 

6.Info balloon

Actual results:
Guest memory does not continue to evict, still keeps original value

Expected results:
Guest memory should begin continue evicting ,the value of memoy after ballooning should be 1024

Additional info:
Comment 2 dawu 2012-08-01 23:36:08 EDT
This issue does not reproduce on virtio-win-1.5.3,set it to regression.

Thanks!
Best Regards,
Dawn
Comment 5 Vadim Rozenfeld 2012-09-09 10:30:53 EDT
Regression. Should be fixed in build 35
http://download.devel.redhat.com/brewroot/packages/virtio-win-prewhql/0.1/35/win/virtio-win-prewhql-0.1.zip
Comment 6 dawu 2012-09-13 04:27:33 EDT
Reproduce this bug on virtio-win-prewhql-30 and verified this bug on virtio-win-prewhql-35 with following following steps in comment #0

environment:
virtio-win-prewhql-35
kernel-2.6.32-301.el6.x86_64
qemu-kvm-0.12.1.2-2.307.el6.x86_64

Actual Results:
on version virtio-win-prewhql-30,bug can reproduced.
on version virtio-win-prewhql-35,balloon can continue to evict.

Based on above ,this issue haven't fixed yet,reassign this bug.
Comment 9 dawu 2012-09-13 06:07:20 EDT
(In reply to comment #6)
> Reproduce this bug on virtio-win-prewhql-30 and verified this bug on
> virtio-win-prewhql-35 with following following steps in comment #0
> 
> environment:
> virtio-win-prewhql-35
> kernel-2.6.32-301.el6.x86_64
> qemu-kvm-0.12.1.2-2.307.el6.x86_64
> 
> Actual Results:
> on version virtio-win-prewhql-30,bug can reproduced.
> on version virtio-win-prewhql-35,balloon can continue to evict.
> 
> Based on above ,this issue haven't fixed yet,reassign this bug.

Sorry for typing mistake, correct the last sentence as "Based on above ,this issue have been fixed, so move to MODIFIED"

thanks
Best Regards,
Dawn
Comment 11 errata-xmlrpc 2013-02-21 05:40:31 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0441.html

Note You need to log in before you can comment on or make changes to this bug.