Bug 843360 - [balloon]the length of illegal string is too long to check illegal string correctly in qemu
[balloon]the length of illegal string is too long to check illegal string co...
Status: CLOSED DUPLICATE of bug 814072
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.4
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-26 02:44 EDT by Min Deng
Modified: 2012-07-26 03:31 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-26 03:31:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Min Deng 2012-07-26 02:44:05 EDT
Description of problem:
The length of illegal string is too long  to checking illegal string in monitor

Version-Release number of selected component (if applicable):
kernel-2.6.32-279.el6.x86_64
qemu-kvm-0.12.1.2-2.295.el6.x86_64

How reproducible:
Always,

Steps to Reproduce:
1.boot up guest 
  /usr/libexec/qemu-kvm -cpu Penryn,+x2apic,family=0xf -smp 6 -m 4G -device virtio-balloon-pci,id=balloon0 -k en-us -usb -device usb-tablet,id=tablet0 -device intel-hda,id=sound0 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -drive file=/home/win7-32.qcow2,format=qcow2,cache=none,if=none,werror=stop,rerror=stop,id=drive-disk0,media=disk -device ide-drive,drive=drive-disk0,id=disk0,bootindex=2 -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup -device e1000,netdev=hostnet0,id=net0 -device virtio-serial-pci,id=virtio-serial0,max_ports=16,vectors=4,bus=pci.0 -chardev socket,server,host=0.0.0.0,port=12345,id=channel0,nowait -device virtserialport,chardev=channel0,nr=1,id=serialport.1,name=org.linux-kvm.port0,bus=virtio-serial0.0 -rtc base=utc,clock=host,driftfix=slew -name winxp -spice port=5930,disable-ticketing -vga qxl -uuid 43c1afba-2d72-4c71-a984-51dac0e588ca -monitor stdio -drive file=/home/en_windows_7_ultimate_with_sp1_x86_dvd_619077.iso,format=raw,if=none,media=cdrom,id=drive-ide0-1-0 -device ide-drive,drive=drive-ide0-1-0,id=ide-drive0,bootindex=1 -drive file=/usr/share/virtio-win/virtio-win-1.5.3.iso,media=cdrom,cache=none,werror=stop,format=raw -fda /usr/share/virtio-win/virtio-win-1.5.3.vfd -chardev socket,id=111a,path=/tmp/monitor-732,server,nowait -mon chardev=111a,mode=readline -bios /usr/share/seabios/bios-pm.bin
2.From monitor,
(qemu) balloon -1111111111111
Parameter 'target' expects a size
(qemu) balloon -111111111111111111111111  
...
(qemu) balloon -99999999999999999999999999999999
...
(qemu) info balloon
balloon: actual=304
 
Actual results:
Obviously,those values were illegal.it should provide warning message.
Expected results:
Warning message should provide here.


Additional info:
Comment 1 Mike Cao 2012-07-26 03:31:01 EDT

*** This bug has been marked as a duplicate of bug 814072 ***

Note You need to log in before you can comment on or make changes to this bug.