Bug 843412 - /opt/rh/httpd24/root/lib64 installed but not packaged
/opt/rh/httpd24/root/lib64 installed but not packaged
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: scl-utils (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-26 05:05 EDT by Jan Kaluža
Modified: 2013-07-02 19:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-02 07:05:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kaluža 2012-07-26 05:05:36 EDT
Probably after some update (I haven't tested httpd24 collection build for 2 months), %scl_files macro stopped including /opt/rh/httpd24/root/lib64 for some reason. When I add this directory into %files manually, it works as expected.

scl-utils           x86_64     20120613-1.fc17
scl-utils-build     x86_64     20120613-1.fc17
Comment 1 Jindrich Novy 2012-09-06 16:07:04 EDT
Actually the base filesystem ownership macros contain the following:
%ifarch x86_64 ppc ppc64 sparc sparc64 s390 s390x
%{_scl_root}/%{_lib}
%endif

which should correctly expand to e.g. /opt/rh/httpd24/root/lib64 when built on x86_64. Wasn't the package in question attempeted to be built for 32bit on x86_64?
Comment 2 Jan Kaluža 2012-09-07 02:27:47 EDT
It works. Maybe some update fixed it but I'm pretty sure I haven't changed anything in .spec file during those two months mentioned in Comment 0 and it failed to rebuild. But yes, now it's working as expected, so you can close this bug. Thanks.
Comment 3 Jan Zeleny 2012-09-07 02:46:55 EDT
Since this is working, I'm closing the bug.
Comment 4 Jan Kaluža 2012-09-07 04:15:37 EDT
Hm, so I have update. It still happens in my fedora-16-x86_64 mock:

error: Installed (but unpackaged) file(s) found:
   /opt/rh/httpd24/root/lib64
    Installed (but unpackaged) file(s) found:
   /opt/rh/httpd24/root/lib64
RPM build errors:

Spec file is here: http://jkaluza.fedorapeople.org/httpd24.spec

For RHEL6 it works correctly using mock.
Comment 5 Jan Kaluža 2012-09-07 04:16:11 EDT
Of course I meant fedora-17-x86_64 in previous comment...
Comment 6 Jindrich Novy 2012-09-10 10:29:13 EDT
Yet a few questions.

Assuming this doesn't happen when you make a normal non-SCL build of the package? Is the scl-utils installed of x86_64 arch? Could you please provide me with a SRPM to let me test the build failure?

Thanks!
Comment 7 Jindrich Novy 2012-09-10 10:40:40 EDT
Could you please try this update?
https://admin.fedoraproject.org/updates/scl-utils-20120809-1.fc17

(currently in updates-testing)
Comment 8 Jan Kaluža 2012-09-24 03:40:42 EDT
Sorry for delay, I was on holiday. This version does not fix the problem for me. I will upload srpms and paste link here.
Comment 9 Jan Kaluža 2012-09-24 04:19:15 EDT
SRPM is here: http://repos.fedorapeople.org/repos/jkaluza/httpd24/fedora-17/SRPMS/httpd24-1-1.fc17.src.rpm

For now I'm building it like this (Those --install are little bit useless now, but should not cause any problem):

mock -r "$CONFIG" --init
mock -r "$CONFIG" --install scl-utils
mock -r "$CONFIG" --install scl-utils-build
mock -r "$CONFIG" --install iso-codes
mock -r "$CONFIG" --no-clean  --rebuild /home/hanzz/rpmbuild/SRPMS/httpd24-1*.src.rpm --define 'scl httpd24'
Comment 10 Jan Kaluža 2012-09-24 04:21:49 EDT
CONFIG is fedora-17-x86_64 in my case.
Comment 11 Jan Zeleny 2012-10-02 07:05:13 EDT
After a consultation with the reporter I'm closing the bug as NOTABUG. It seems that the issue was caused by the package being built as noarch. In that case the core of this bug is documented "feature" of scl-utils.

Note You need to log in before you can comment on or make changes to this bug.