Bug 843423 - mysql -D results in showing the usage page ( EASY FIXABLE )
mysql -D results in showing the usage page ( EASY FIXABLE )
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mysql (Show other bugs)
16
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Tom Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-26 05:49 EDT by customercare
Modified: 2012-07-31 10:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-31 10:28:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description customercare 2012-07-26 05:49:23 EDT
Description of problem:

"mysql -D dbname ..." results in showing the usage page, instead of using the argument as databasename . If the "-D" gets removed from the cmdline, it works as expected. 

Version-Release number of selected component (if applicable):

5.5.25a

How reproducible:

100%

Steps to Reproduce:
[root@ mysqldumps]# mysql -u root -pXXXXXXXXX –D dbname < traffic_ip
  
Actual results:

[root@ mysqldumps]# mysql -u root -pXXXXXXX –D dbname < traffic_ip
mysql  Ver 14.14 Distrib 5.5.25a, for Linux (x86_64) using readline 5.1
Copyright (c) 2000, 2011, Oracle and/or its affiliates. All rights reserved.

Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective
owners.

Usage: mysql [OPTIONS] [database]
  -?, --help          Display this help and exit.
....

Expected results:

Importing the SQL , as -D is mentioned in the shown help as the Databasename:

  ...
  -T, --debug-info    Print some debug info at exit.

  -D, --database=name Database to use.

  --default-character-set=name
                      Set the default character set.  
  ...
Comment 1 Tomas Hoger 2012-07-31 08:46:01 EDT
(In reply to comment #0)

> [root@ mysqldumps]# mysql -u root -pXXXXXXXXX –D dbname < traffic_ip

Try using -D and not –D.  The above seems to be using some unicode dash character and not minus.  Try typing it in manually if this was copy-n-pasted from somewhere.
Comment 2 customercare 2012-07-31 10:28:06 EDT
it seems like this is true. 

We are sorry for reporting it.

Note You need to log in before you can comment on or make changes to this bug.