Bug 843454 - ovirt-engine-backend: deactivate storage domain is sent with domain id only which will fail tasks running on pool when the domain is the master domain
ovirt-engine-backend: deactivate storage domain is sent with domain id only w...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
urgent Severity urgent
: ---
: ---
Assigned To: Yair Zaslavsky
Dafna Ron
infra
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-26 07:19 EDT by Dafna Ron
Modified: 2016-02-10 14:14 EST (History)
11 users (show)

See Also:
Fixed In Version: si13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 14:58:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log (141.75 KB, application/x-xz)
2012-07-26 07:19 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-07-26 07:19:48 EDT
Created attachment 600488 [details]
log

Description of problem:

when we deactivate a domain we are only sending the domain id which is good for all domains except the master domain since putting master in maintenance will copy metadata of pool to other domain and if there are any tasks running on any other domain in the pool it will fail the tasks. 

Version-Release number of selected component (if applicable):

si11

How reproducible:

100%

Steps to Reproduce:
1. create a pool on non-master domain
2. put master domain in maintenance 
3.
  
Actual results:

we will be able to deactivate the master domain which will trigger a reconstruct of domain and tasks will fail

Expected results:

we should send pool id in task query as well as domain id to the vdsm if we are trying to deactivate the master domain

Additional info:engine log
Comment 1 Yair Zaslavsky 2012-07-27 01:16:47 EDT
After consulting with Michael Kublin -
We will not deactivate storage domain if its is master and there are running tasks on the pool.
For other storage domains we will keep current behavior.
Comment 2 Yair Zaslavsky 2012-07-28 04:37:20 EDT
Suggested patch

http://gerrit.ovirt.org/#/c/6691/

Note You need to log in before you can comment on or make changes to this bug.