Bug 843468 - 3.0.z - [rhevm-dwh] - History DB - Duplicate records in History Aggregation Views
3.0.z - [rhevm-dwh] - History DB - Duplicate records in History Aggregation V...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-dwh (Show other bugs)
3.0.3
x86_64 Linux
unspecified Severity high
: ---
: 3.0.8
Assigned To: Yaniv Lavi
David Botzer
infra
: ZStream
Depends On: 838962
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-26 08:18 EDT by Chris Pelland
Modified: 2016-02-10 14:04 EST (History)
10 users (show)

See Also:
Fixed In Version: si22 - rhevm-dwh-3.1.0-16.el6ev.noarch.rpm
Doc Type: Bug Fix
Doc Text:
The Extract, Transform, Load (ETL) process previously aggregated history information incorrectly. This resulted in duplicate records appearing in the database views. The ETL process has been updated and now correctly aggregates history information for all objects. Duplicate records no longer appear in the database views.
Story Points: ---
Clone Of: 838962
Environment:
Last Closed: 2012-11-27 14:57:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 Stephen Gordon 2012-10-24 15:39:56 EDT
Yaniv, what is the difference between this and Bug #868937 on the same errata?
Comment 4 Yaniv Lavi 2012-11-01 09:25:02 EDT
This is a wide issue cause by the aggregation process adding duplicate rows.
The other issue affects only disk usage and is caused due to a talend code generation issue.




Yaniv
Comment 5 Stephen Gordon 2012-11-01 09:26:32 EDT
(In reply to comment #4)
> This is a wide issue cause by the aggregation process adding duplicate rows.
> The other issue affects only disk usage and is caused due to a talend code
> generation issue.
> 
> 
> 
> 
> Yaniv

Thanks, I will rewrite the documentation text on this one to highlight that it is a more generic issue.
Comment 6 David Botzer 2012-11-08 03:32:02 EST
Fixed, 3.1/si24 (remote, Local, Clean & Upgraded)
No Dupicates in history db views:
v3_1_vm_hourly_history_view
v3_1_vm_daily_history_view
v3_1_vm_interface_hourly_history_view
v3_1_vm_interface_daily_history_view
v3_1_vm_disk_hourly_history_view
v3_1_vm_disk_daily_history_view
Fixed, 3.1/si24 (remote, Local, Clean & Upgraded)
Comment 8 errata-xmlrpc 2012-11-27 14:57:35 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1497.html

Note You need to log in before you can comment on or make changes to this bug.