Bug 843491 - Favourite channels are disappearing in empathy [NEEDINFO]
Favourite channels are disappearing in empathy
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: empathy (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity medium
: beta
: ---
Assigned To: Debarshi Ray
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-26 09:03 EDT by Vitezslav Humpa
Modified: 2014-06-18 03:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 08:33:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mcepl: needinfo? (debarshir)


Attachments (Terms of Use)

  None (edit)
Description Vitezslav Humpa 2012-07-26 09:03:29 EDT
Description of problem:
Favourite chat rooms are going to disappear from the Room menu unless you check them for 'Auto Connect' in the 'Manage Favorite' dialog. Auto connecting feature serves to auto open channel in conversation window on empathy start-up. However this should not have influence on when one simply toggles a channel favourite without it being auto-opened. (Meaning you should be able to have favourite channels that are not this semi-persistently connected)

Version-Release number of selected component (if applicable):
empathy-3.4.2.1-1.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Join a #channel (IRC or Jabber conference...)
2. Toggle 'Conversation -> Favorite Chat Room' on
3. See the Room menu in the Contact list - channel is there among favourites
4. Close the conversation window
5. See the menu now
  
Actual results:
Channel is gone from the Room menu

Expected results:
It is still present unless you choose to remove it from favorites

Additional:
Didn't find the same bug upstream yet
Comment 1 Debarshi Ray 2012-10-31 11:26:53 EDT
Confirmed. This behaviour exists in 3.6.1 too.
Comment 3 Debarshi Ray 2013-11-01 12:24:31 EDT
Has been fixed in recent versions of empathy-3.8.x that are in RHEL7. Please feel free to reopen if you have reasons to believe otherwise.
Comment 5 Matěj Cepl 2013-12-13 13:51:27 EST
Cannot reproduce with empathy-3.8.4-3.el7.x86_64
Comment 6 Matěj Cepl 2013-12-13 13:54:52 EST
Debarashi, can I ask for review of https://tcms.engineering.redhat.com/case/327426 ... it is a proper test for this bug?
Comment 7 Ludek Smid 2014-06-13 08:33:55 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.