Bug 843516 - ERROR with transaction check vs depsolve
ERROR with transaction check vs depsolve
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-26 10:16 EDT by itsacademic
Modified: 2014-01-21 18:23 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-21 16:00:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description itsacademic 2012-07-26 10:16:36 EDT
Description of problem:
Running Transaction Check
ERROR with transaction check vs depsolve:
libjawt.so is needed by libreoffice-core-1:3.5.5.3-2.fc17.i686
libjawt.so(SUNWprivate_1.1) is needed by libreoffice-core-1:3.5.5.3-2.fc17.i686

** Found 3 pre-existing rpmdb problem(s), 'yum check' output follows:
icedtea-web-1.2-2.fc17.i686 has missing requires of java-1.7.0-openjdk
1:libreoffice-core-3.5.4.2-4.fc17.i686 has missing requires of libjawt.so
1:libreoffice-core-3.5.4.2-4.fc17.i686 has missing requires of libjawt.so(SUNWprivate_1.1)
Your transaction was saved, rerun it with:*****


Version-Release number of selected component (if applicable):
See above

How reproducible:
Always

Steps to Reproduce:
1.sudo yum update
2.
3.
  
Actual results:
See above

Expected results:
Update proceeds successfully

Additional info:
Comment 1 itsacademic 2012-07-31 10:43:20 EDT
Note, with respect to the line:

 icedtea-web-1.2-2.fc17.i686 has missing requires of java-1.7.0-openjdk

this occured because I removed java using 'yum remove java*'. Apparently that does not remove the icedtea-web component, but it seems to be dependent on it.
Comment 2 James Antill 2013-05-21 16:00:37 EDT
There are preexisting rpmdb problems, fix those (via. yum remove, or yum install'ing the missing deps).

Note You need to log in before you can comment on or make changes to this bug.