Bug 843545 - Evince gives a wrong filename to an email client when using the Send To function, should the filename have spaces
Evince gives a wrong filename to an email client when using the Send To funct...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: evince (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: beta
: ---
Assigned To: Marek Kašík
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-26 11:02 EDT by Vitezslav Humpa
Modified: 2014-06-18 04:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 06:52:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vitezslav Humpa 2012-07-26 11:02:09 EDT
Description of problem:
When using the 'Send To' function from Evince using the Email method, evolution fails to open the file for attaching it to the message if the file contained spaces. Reason is that evince replaces spaces with '0' characters in place of escaping them properly.

Version-Release number of selected component (if applicable):
evince-3.4.0-2.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install evolution and make sure it's selected as a default email client, you might also need some email account configured first.
2. In evince, open a file with a filename containing spaces.
3. Do File->Send To, select Email method, type in some address and press Send
  
Actual results:
Evolution starts up complaining it can't open the file for attachment:
(File name was 'sam ple.pdf')
Error dialog in evolution compose message screen:
"Error when getting information for file '/home/vhumpa/documents/sam00ple.pdf': No such file or directory"

Expected results:
Path string has the space characters escaped fine and the file attaches

Additional info:
Relevant terminal output from evince:

** Message: Mailer type: 0
** Message: Command: evolution mailto:"joestalin@cccp.gov"?attach="file:///home/vhumpa/documents/sam00ple.pdf"
Comment 1 Marek Kašík 2012-10-24 13:04:11 EDT
This seems to be fixed in nautilus-sendto-3.6.0-1.el7 and evince-3.6.0-1.el7. The PDF file is attached correctly.
Comment 4 Ludek Smid 2014-06-13 06:52:15 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.