Bug 843563 - Can't use the recording feature of gnome-shell, if the keyboard shortcut conflicts with key layout switching
Can't use the recording feature of gnome-shell, if the keyboard shortcut conf...
Status: CLOSED DUPLICATE of bug 841878
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-shell (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Owen Taylor
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-26 11:57 EDT by Vitezslav Humpa
Modified: 2012-07-26 12:23 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-26 12:23:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vitezslav Humpa 2012-07-26 11:57:30 EDT
Description of problem:
If I setup i.e. Alt-Shift shortcut for switching keyboard layouts, I subsequently can't use the recording feature. It simply conflicts since its own global shortcut Ctrl-Alt-Shift-R has the Alt-Shift contained. This would likely be a problem for any other such subset shortcut.

Version-Release number of selected component (if applicable):
gnome-shell-3.4.1-5.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Using control-center, Region and Language settings->layouts set up multiple layouts to use.
2. Set up the conflicting shortcut for switching using Options... on the same tab
3. Try to record something using Ctrl-Alt-Shift-R
  
Actual results:
Layout will switch instead

Expected results:
You should be at very least be notified and warned that setting such shortcut will make a conflict and you won't be able the recording feature.
Comment 1 Vitezslav Humpa 2012-07-26 12:23:41 EDT
Found https://bugzilla.redhat.com/show_bug.cgi?id=841878 that was reported sooner.

*** This bug has been marked as a duplicate of bug 841878 ***

Note You need to log in before you can comment on or make changes to this bug.