Bug 843564 - [ovirt-engine-config] manage-domains fails due to problems in rhevm config
[ovirt-engine-config] manage-domains fails due to problems in rhevm config
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-config (Show other bugs)
3.1.0
x86_64 Linux
high Severity unspecified
: ---
: ---
Assigned To: Yair Zaslavsky
Pavel Stehlik
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-26 12:04 EDT by Kiril Nesenko
Modified: 2016-02-10 14:01 EST (History)
7 users (show)

See Also:
Fixed In Version: si12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 14:57:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kiril Nesenko 2012-07-26 12:04:16 EDT
Description of problem:
manage-domains fails due to problems in rhevm config

[root@vm-17-13 ~]# rhevm-manage-domains -action=add -domain=qa.lab.tlv.redhat.com -user=vdcadmin -provider=ActiveDirectory -interactive -addPermissions
Enter password:

Exception in thread "main" java.lang.ArrayIndexOutOfBoundsException: 1
        at org.ovirt.engine.core.utils.kerberos.DomainsConfigurationEntry.<init>(DomainsConfigurationEntry.java:24)
        at org.ovirt.engine.core.utils.kerberos.ManageDomains.addDomain(ManageDomains.java:419)
        at org.ovirt.engine.core.utils.kerberos.ManageDomains.runCommand(ManageDomains.java:239)
        at org.ovirt.engine.core.utils.kerberos.ManageDomains.main(ManageDomains.java:164)
[root@vm-17-13 ~]#




Version-Release number of selected component (if applicable):
si12

How reproducible:


Steps to Reproduce:
1. Try to run rhevm-manage-domains
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Yair Zaslavsky 2012-07-26 12:09:05 EDT
As rhevm-manage-domains executes rhevm-config and relies on its output, the output must contain only valid information in the format that rhevm-manage-domains expects.
Comment 3 Yair Zaslavsky 2012-07-26 14:54:19 EDT
In reply to comment #2, this matches gerrit patch at http://gerrit.ovirt.org/#/c/6665/

Note You need to log in before you can comment on or make changes to this bug.