Bug 843602 - optical disk tests (cdrom, dvd, bluray) should not use HAL
optical disk tests (cdrom, dvd, bluray) should not use HAL
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
1.6.4
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caspar Zhang
Red Hat Kernel QE team
:
Depends On:
Blocks: 851892
  Show dependency treegraph
 
Reported: 2012-07-26 14:16 EDT by Greg Nichols
Modified: 2013-02-01 13:20 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: optical disk tests(cdrom, dvd, bluray) use udev for hardware detection in test planning and execution. Reason: HAL is deprecated in RHEL6. Result (if any): Note: Due to a known issue in RHEL6.3 or earlier releases, please put a disk in device drive before you do `v7 plan` if you're going to do ceritification in RHEL6.3 or prior release.
Story Points: ---
Clone Of:
: 843604 (view as bug list)
Environment:
Last Closed: 2013-02-01 13:20:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Nichols 2012-07-26 14:16:11 EDT
Description of problem:

The optical disk tests should not use HAL for test planning or execution.


Version-Release number of selected component (if applicable):

v7 1.6.4
Comment 1 Greg Nichols 2012-08-03 12:48:49 EDT
The code that uses hal (via v7.Hal and calls to lshal) can be replaced with UDisks (see v7.UDiskDeviceDetector, currently used by the storage test).
Comment 16 errata-xmlrpc 2013-02-01 13:20:46 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0222.html

Note You need to log in before you can comment on or make changes to this bug.