Bug 843604 - battery test should not use HAL
battery test should not use HAL
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
1.6.4
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caspar Zhang
Red Hat Kernel QE team
:
Depends On:
Blocks: 850704 851892
  Show dependency treegraph
 
Reported: 2012-07-26 14:19 EDT by Greg Nichols
Modified: 2013-02-01 13:20 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: battery test uses udev for hardware detection in test planning and execution. Reason: HAL is deprecated in RHEL6. Result (if any):
Story Points: ---
Clone Of: 843602
: 843605 850704 (view as bug list)
Environment:
Last Closed: 2013-02-01 13:20:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Nichols 2012-07-26 14:19:27 EDT
Description of problem:

The battery test should not use HAL for test planning or execution.


Version-Release number of selected component (if applicable):

v7 1.6.4
Comment 1 Greg Nichols 2012-07-30 16:51:44 EDT
It looks like udev (v7/UdevDeviceDetectory.py) should work for the battery test.
Here's an example:

udev device: /devices/LNXSYSTM:00/device:00/PNP0A08:00/device:01/PNP0C09:00/PNP0C0A:00/power_supply/BAT0
------------------------------------------------------
SUBSYSTEM power_supply
POWER_SUPPLY_NAME BAT0
POWER_SUPPLY_MODEL_NAME COMPATIBLE
POWER_SUPPLY_SERIAL_NUMBER  3660
info.udi /devices/LNXSYSTM:00/device:00/PNP0A08:00/device:01/PNP0C09:00/PNP0C0A:00/power_supply/BAT0
DEVPATH /devices/LNXSYSTM:00/device:00/PNP0A08:00/device:01/PNP0C09:00/PNP0C0A:00/power_supply/BAT0
POWER_SUPPLY_TECHNOLOGY Li-ion
POWER_SUPPLY_VOLTAGE_NOW 12447000
POWER_SUPPLY_ENERGY_FULL_DESIGN 71280000
POWER_SUPPLY_POWER_NOW 0
POWER_SUPPLY_ENERGY_NOW 60170000
POWER_SUPPLY_ENERGY_FULL 60180000
POWER_SUPPLY_STATUS Unknown
POWER_SUPPLY_CYCLE_COUNT 0
POWER_SUPPLY_PRESENT 1
POWER_SUPPLY_MANUFACTURER SANYO
POWER_SUPPLY_VOLTAGE_MIN_DESIGN 10800000
Comment 27 errata-xmlrpc 2013-02-01 13:20:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0222.html

Note You need to log in before you can comment on or make changes to this bug.