Bug 843652 - luakit FTBFS with recent glib
luakit FTBFS with recent glib
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: luakit (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pierre Carrier
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-26 18:05 EDT by Tom Lane
Modified: 2013-07-02 23:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-01 12:19:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
update glib includes (3.14 KB, patch)
2012-07-26 18:05 EDT, Tom Lane
no flags Details | Diff

  None (edit)
Description Tom Lane 2012-07-26 18:05:12 EDT
Created attachment 600616 [details]
update glib includes

Description of problem:
luakit has failed the last couple of mass rebuilds in Fedora.  The reason is that glib now insists that you only include <glib.h> and not any of the individual header files that used to be available.  I attach a patch to fix it.

Version-Release number of selected component (if applicable):
luakit-2011.07.22.r1-4.fc18.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Try to build in rawhide.
Comment 1 Gwyn Ciesla 2012-08-01 12:19:53 EDT
Committed and build in rawhide.

Note You need to log in before you can comment on or make changes to this bug.