Bug 843661 - wmdrawer FTBFS
wmdrawer FTBFS
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: wmdrawer (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mario Blättermann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-26 19:10 EDT by Tom Lane
Modified: 2013-07-02 23:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-28 12:08:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
move dos2unix call to %prep section (803 bytes, patch)
2012-07-26 19:10 EDT, Tom Lane
no flags Details | Diff

  None (edit)
Description Tom Lane 2012-07-26 19:10:58 EDT
Created attachment 600633 [details]
move dos2unix call to %prep section

Description of problem:
wmdrawer has failed the last couple of Fedora mass rebuilds.  The problem seems to be that the specfile assumes that %install runs after RPM has copied the %doc files to the install tree; which is not true now and may never have been true.  I attach a specfile patch that fixes this.

Version-Release number of selected component (if applicable):
wmdrawer-0.10.5-13.fc18.x86_64

How reproducible:
100%

Steps to Reproduce:
1.  Try to build in rawhide.
Comment 1 Mario Blättermann 2012-07-28 12:08:33 EDT
Thanks for reporting this. I have applied your patch to the master branch.

Succesful build:
http://koji.fedoraproject.org/koji/buildinfo?buildID=344781

Note You need to log in before you can comment on or make changes to this bug.