Bug 843784 - Make ovirtfunctions.py top-level code conditional
Make ovirtfunctions.py top-level code conditional
Status: CLOSED DUPLICATE of bug 1008934
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mike Burns
:
Depends On:
Blocks: 843777
  Show dependency treegraph
 
Reported: 2012-07-27 07:18 EDT by Fabian Deutsch
Modified: 2013-11-28 10:08 EST (History)
6 users (show)

See Also:
Fixed In Version: 2.7.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-28 10:08:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabian Deutsch 2012-07-27 07:18:16 EDT
Description of problem:
Currently there is top-level code in the ovirtfunctions.py file which is executed when this module get's imported, this is a problem for some checks - mainly because this code relies on runtime informations (e.g. /etc/default/node).
Comment 1 Fabian Deutsch 2013-11-28 10:08:23 EST

*** This bug has been marked as a duplicate of bug 1008934 ***

Note You need to log in before you can comment on or make changes to this bug.