Bug 843792 - Fix statedump code in write-behind xlator
Fix statedump code in write-behind xlator
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: write-behind (Show other bugs)
3.3.0
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Raghavendra Bhat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-27 07:41 EDT by Pranith Kumar K
Modified: 2013-07-24 13:42 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:42:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2012-07-27 07:41:02 EDT
Description of problem:
remove gf_logs in statedump codepath.
locks acquired in statedump codepath should not be blocking. Please change the calls to try_lock variants.

This bug is logged because this xlator violates the above rules.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2012-10-11 21:12:21 EDT
CHANGE: http://review.gluster.org/4036 (performance/write-behind: use try lock while taking statedumps) merged in master by Anand Avati (avati@redhat.com)

Note You need to log in before you can comment on or make changes to this bug.