Bug 843801 - User should not be allowed to set "To" date lesser than "From" date on Log Filter
User should not be allowed to set "To" date lesser than "From" date on Log Fi...
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Tzu-Mainn Chen
Rehana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-27 07:58 EDT by Rehana
Modified: 2012-12-04 10:15 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
If a user set a "To" date that would be less than the "From" date, no error message displayed to inform the user of the error. This fix now includes an appropriate error message that displays in this situation: "'From date' cannot be after 'To date'".
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:15:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
filter_by_date (181.00 KB, image/png)
2012-07-27 07:58 EDT, Rehana
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:1516 normal SHIPPED_LIVE CloudForms Cloud Engine 1.1 update 2012-12-04 14:51:45 EST

  None (edit)
Description Rehana 2012-07-27 07:58:01 EDT
Created attachment 600752 [details]
filter_by_date

Description of problem:

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.login to conductor as admin
2.Go to Monitor --> logs
3.Set "TO" date lesser than from date (PFA:filter_by_date.png)
4.click on Apply filter


  
Actual results:
nothing displayed.

Expected results:
Even though no imformation is displayed, it will be good to show some appropriate error message like "To date cannot be lesser than From date" or so

Additional info:

rpm -qa | grep aeolus
rubygem-aeolus-cli-0.6.0-0.20120723230034git2a28761.fc16.noarch
aeolus-conductor-0.11.0-0.20120725030008gitcdc50c9.fc16.noarch
rubygem-aeolus-image-0.6.0-0.20120723230037git05a815a.fc16.noarch
aeolus-conductor-doc-0.11.0-0.20120725030008gitcdc50c9.fc16.noarch
aeolus-all-0.11.0-0.20120725030008gitcdc50c9.fc16.noarch
aeolus-configure-2.7.0-0.20120723230032gitcc8302d.fc16.noarch
aeolus-conductor-daemons-0.11.0-0.20120725030008gitcdc50c9.fc16.noarch
Comment 1 Tzu-Mainn Chen 2012-08-14 11:30:31 EDT
Patch created:

http://lists.fedorahosted.org/pipermail/aeolus-devel/2012-August/012022.html
Comment 2 Matt Wagner 2012-08-15 12:29:12 EDT
Pushed to master and 1.1 (shown below):

commit 2e3e698781d63f8cef9bfb64638ef78c432fc580
Author: Tzu-Mainn Chen <tzumainn@redhat.com>
Date:   Tue Aug 14 11:29:17 2012 -0400

    BZ 843801 add error if from date is after to date
    
    Signed-off-by: Matt Wagner <matt.wagner@redhat.com>
    (cherry picked from commit 82edd4e795ab78dfe32570d92396c708929bd9bd)
Comment 4 Rehana 2012-09-20 06:04:04 EDT
Error message displayed "'From date' cannot be after 'To date'"

verified on 

 rpm -qa | grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch
aeolus-all-0.13.8-1.el6cf.noarch
aeolus-conductor-0.13.8-1.el6cf.noarch
aeolus-configure-2.8.6-1.el6cf.noarch
Comment 6 errata-xmlrpc 2012-12-04 10:15:35 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.