Bug 84381 - Installer hangs when initially creating user preferences
Summary: Installer hangs when initially creating user preferences
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: openoffice.org (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Dan Williams
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-15 06:23 UTC by Chris Sherlock
Modified: 2007-04-18 16:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-27 16:13:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
stack trace (10.26 KB, text/plain)
2003-02-15 06:24 UTC, Chris Sherlock
no flags Details
"/usr/lib/openoffice/program/setup -R:/etc/openoffice/autoresponse.conf" (80.50 KB, application/octet-stream)
2003-02-15 07:55 UTC, Chris Sherlock
no flags Details

Description Chris Sherlock 2003-02-15 06:23:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
I have installed Open Office 1.0.2 from rawhide. I cannot get the program to
start initially!

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Type in ooffice at the command prompt
2. The following comes up on the screen:

Checking for existing user installation ...   ...   NOT FOUND
Performing first-time installation for user ... 

3. I have to kill the install.

Actual Results:  I get the following text:

Checking for existing user installation ...   ...   NOT FOUND
Performing first-time installation for user ... ... FAILED

Expected Results:  Open Office should have started!

Additional info:

I can do a strace on it. Incidently, this occurs when I am logged in as root also.

Comment 1 Chris Sherlock 2003-02-15 06:24:19 UTC
Created attachment 90101 [details]
stack trace

This is a stack trace output of ooffice command on my system. Note I had to
kill it.

Comment 2 Chris Sherlock 2003-02-15 07:55:52 UTC
Created attachment 90103 [details]
"/usr/lib/openoffice/program/setup -R:/etc/openoffice/autoresponse.conf"

The ooffice shell script seems to crash when it gets to the line:

"/usr/lib/openoffice/program/setup -R:/etc/openoffice/autoresponse.conf"

I'm attaching a stack trace again of this particular program.
Apologies for the fact that it's gzipped up - the proxy I am behind
won't let me upload the file as it's too large.

Comment 3 Chris Sherlock 2003-02-15 08:34:35 UTC
Doing further testing, it is actually /usr/lib/openoffice/program/setup.bin that
is crashing the install. Without the auto configuration file, the first bit of
the window opens, but then it totally freezes. 

The last two lines of the strace are:

rt_sigprocmask(SIG_SETMASK, NULL, [RTMIN], 8) = 0
rt_sigsuspend([]

Comment 4 Jakub Jelinek 2003-02-18 12:54:02 UTC
Which exact rpm version (1.0.2-1 or 1.0.2-2)?
Was this on an account which used openoffice-1.0.1-X previously or account
without ~/.openoffice directory before the upgrade?

Comment 5 Chris Sherlock 2003-02-20 13:40:11 UTC
I'm using openoffice 1.0.2-2. I previously used openoffice-1.0.1.X (can't
remember which one, it was off a downloaded ISO of Redhat 8.0, this has a
~./openoffice directory before the upgrade. 

Comment 6 Chris Sherlock 2003-02-24 13:53:18 UTC
Also occurs in openoffice-1.0.2-4

Comment 7 Chris Sherlock 2003-02-27 08:33:02 UTC
Two things. First of all that "stack trace" ain't a stack trace. Oops. Got a bit
confused there. 

2nd thing. I grabbed glibc-2.3.1-51 as a source RPM, built it and upgraded from
glibc-2.3.1-41 and now OpenOffice is working. This was the problem. 

Now... do you want me to close this, or do you want to do something with it? 

Comment 8 Mike A. Harris 2003-03-12 16:14:11 UTC
If the problem isn't reproduceable with a fresh installation of our last
phoebe beta with all rawhide software updates released since applied,
personally I wouldn't consider it a bug, since we do not officially
support rawhide packages installed on older OS releases.

Wether or not there is/was a real bug and whatnot, I'll leave up to
someone else to decide, as well as what to do with this report.  ;o)

Comment 9 Chris Sherlock 2003-03-13 08:23:15 UTC
No probs. At the very least I guess someone might do a search for it and find it...

Comment 10 Robin Green 2003-03-16 15:08:06 UTC
>  At the very least I guess someone might do a search for it and find it...

Thanks Chris! This gave me a clue as to how to workaround the problem!

Comment 11 Dan Williams 2004-02-27 16:13:58 UTC
Please try current OOo 1.1.0, and reopen if problem still occurs


Note You need to log in before you can comment on or make changes to this bug.