Bug 843821 - Fix statedump code in server xlator
Fix statedump code in server xlator
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: protocol (Show other bugs)
3.3.0
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Raghavendra Bhat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-27 08:48 EDT by Pranith Kumar K
Modified: 2013-07-24 14:02 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 14:02:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2012-07-27 08:48:41 EDT
Description of problem:
remove gf_logs in statedump codepath.
locks acquired in statedump codepath should not be blocking. Please change the calls to try_lock variants.

This bug is logged because this xlator violates the above rules.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Raghavendra Bhat 2012-09-27 02:54:36 EDT
 http://review.gluster.com/3764 has been submitted and accepted.

Note You need to log in before you can comment on or make changes to this bug.