Bug 843822 - [FEAT] Fix statedump code in dht xlator
[FEAT] Fix statedump code in dht xlator
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
3.3.0
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: Raghavendra Bhat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-27 08:52 EDT by Pranith Kumar K
Modified: 2013-07-24 13:30 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:30:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2012-07-27 08:52:31 EDT
Description of problem:
remove gf_logs in statedump codepath.
locks acquired in statedump codepath should not be blocking. Please change the calls to try_lock variants.

This bug is logged because this xlator violates the above rules.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Pranith Kumar K 2012-08-18 00:18:13 EDT
Vs,
 I think the fix for the bug consists of < 10 lines removal in dht. I would not consider this a FEAT.

Pranith.
Comment 2 Raghavendra Bhat 2012-10-23 14:40:39 EDT
http://review.gluster.org/#change,4088 handles it.
Comment 3 Vijay Bellur 2012-10-25 03:55:24 EDT
http://review.gluster.org/#change,4117 actually fixes it.
Comment 4 Vijay Bellur 2012-11-19 05:58:22 EST
CHANGE: http://review.gluster.org/4117 (cluster/dht: dump the layout information of directories only) merged in master by Vijay Bellur (vbellur@redhat.com)

Note You need to log in before you can comment on or make changes to this bug.