Bug 843828 - move /boot/grub/splash.xpm.gz to /boot/grub2/
move /boot/grub/splash.xpm.gz to /boot/grub2/
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-27 09:27 EDT by Harald Reindl
Modified: 2012-07-27 11:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-27 11:21:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Reindl 2012-07-27 09:27:20 EDT
can someone please decide if we are using /boot/grub/ or /boot/grub2/ in F17?
not enough that the horrible grub2-mkconfig needs "> /boot/grub2/grub.cfg" instead of working with least surprise and MAKE the config instead display it now we are bothered with broken auto-completion for a splash-image while in F16 i removed /boot/grub/ on all more than 20 machines

[root@srv-rhsoft:~]$ cat /boot/grub
grub/  grub2/ 
[root@srv-rhsoft:~]$ cat /boot/grub/splash.xpm.gz
Comment 1 Mads Kiilerich 2012-07-27 09:54:38 EDT
F17 use grub and /boot/grub for EFI and grub2 and /boot/grub2 for BIOS.

Anaconda creates grub configuration that use splash.xpm.gz .

For f17 the idea was that anaconda should create configuration that used /boot/grub2/themes/system/ . It had to be disabled but will probably be back for f18. splash.xpm.gz never had anything to do with grub2.

The "solution" described in the subject is thus wrong no matter what.

It is quite a bit of exaggeration to call the presence of one unnecessary file that cause a single extra key stroke for "broken auto-complete". But whatever you think the problem is I don't see what it has to do with the grub2.

(That the grub2 package contains Fedora artwork is IMO a bug; it should be placed in a system-logos package and thus move in the opposite direction of what you propose.)

The grub package will probably be unused in f18 and splash.xpm.gz can thus perhaps be removed from system-logos. I guess grub2 in f19 will replace grub completely and take its name.

You should not use ">" for grub2-mkconfig. As mentioned in /usr/share/doc/grub2-tools-2.0/README.Fedora you should use "grub2-mkconfig -o /boot/grub2/grub.cfg" to help make sure you don't end up with invalid configuration. Please help correct any wrong documentation you might have found.

I don't see why your opinion on grub2-mkconfig is relevant for this issue.

(The bug report was written in an agressive tone. This response might reflect that ;-) )
Comment 2 Harald Reindl 2012-07-27 10:29:05 EDT
this machine did not see anaconda since it was installed with F14
so /boot/grub/splash.xpm.gz was surely not installed by anaconda

on all F16 machines /boot/grub/ is removed
the currently to F17 upgraded ones contain it again

the ">" for grub2-mkconfig came on the mailing-list after i ranted why in the world my changes in /etc/grub/default are not reflected in my boot-configration

however, it is still WRONG have to use "-o /boot/grub2/grub.cfg" because it misses the principle of least surprise and needs the user knows where the config-file should be placed

this is PLAIN WRONG, the user has only to know "grub2-mkconfig" and not bother about distribution config details so the opposite behavior like "--printonly" would be correct
Comment 3 Mads Kiilerich 2012-07-27 10:52:03 EDT
(In reply to comment #2)
> this machine did not see anaconda since it was installed with F14
> so /boot/grub/splash.xpm.gz was surely not installed by anaconda

# rpm -qf /boot/grub/splash.xpm.gz
fedora-logos-17.0.2-1.fc17.noarch

> the ">" for grub2-mkconfig came on the mailing-list after i ranted why in
> the world my changes in /etc/grub/default are not reflected in my
> boot-configration

So you ranted before reading /usr/share/doc/grub2-tools-2.0/README.Fedora ?

> however, it is still WRONG have to use "-o /boot/grub2/grub.cfg" because it
> misses the principle of least surprise and needs the user knows where the
> config-file should be placed

It would be very surprising for those who actually know grub 2 if grub2-mkconfig on Fedora had a different default than upstream and in other distros.

A kind request for an improvement in this area can be found in bug 740953.

FWIW: Ranting and yelling and making bold statements in the bugtracker without doing any research do not at all make you look like someone that is worth listening to.
Comment 4 Harald Reindl 2012-07-27 11:00:10 EDT
> So you ranted before reading /usr/share/doc/grub2-tools-2.0/README.Fedora

i ranted after seeing all the config-crap looking like the wildest shellscript-orgasm making grub2 a nightmare at all and after find how to add a simple kernel parameter and found a command that sounds like "damned write this config i defined" which did not what any normal human would expect 

nobody without IT education from a university will ever be able to make a stable grub-configuration while he can honestly say he knows what he is doing

grub2 is broken by design and if anything is spit into /boot/grub* it is logical at the first step to shout at grub2

BTW:
the grub2-final package from rahide is terrible broken, after grub2-install no longer boots and for F16/F17 it would be time to get a FINAl RELEASE which is not broken instead a beta6

P.S.: yes i do NOT like grub2
Comment 5 Mads Kiilerich 2012-07-27 11:21:26 EDT
My conclusion: you are trolling and ranting, not reporting a bug.

Note You need to log in before you can comment on or make changes to this bug.