Bug 843851 - "Url translation missing" error when adding a new provider
"Url translation missing" error when adding a new provider
Status: CLOSED WONTFIX
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Jozef Zigmund
Rehana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-27 10:55 EDT by Ronelle Landy
Modified: 2012-11-28 15:26 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-21 11:36:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Openstack Provider error (230.45 KB, image/png)
2012-07-27 10:55 EDT, Ronelle Landy
no flags Details
Valid URI error (100.24 KB, image/png)
2012-09-20 18:48 EDT, Ronelle Landy
no flags Details

  None (edit)
Description Ronelle Landy 2012-07-27 10:55:25 EDT
Created attachment 600802 [details]
Openstack Provider error

Description of problem:

Looking to test out if I could use my HP Openstack account with Conductor, I tried to add a new Openstack provider. After I entered text in the Openstack API_ENTRYPOINT text box and clicked 'Save Provider', the follow error appeared:

*******
    Cannot add the provider.

Errors

    1 error prohibited this Provider from being saved
    Url translation missing: en.activerecord.errors.models.provider.attributes.url.invalid_framework
******* 

See attached screenshot.


Version-Release number of selected component (if applicable):

rpms tested on F16 ....

>> rpm -qa |grep aeolus
rubygem-aeolus-image-0.6.0-0.20120726120027git05a815a.fc16.noarch
rubygem-aeolus-cli-0.6.0-0.20120726120024git2a28761.fc16.noarch
aeolus-conductor-0.11.0-0.20120726160007git373f3dc.fc16.noarch
aeolus-conductor-doc-0.11.0-0.20120726160007git373f3dc.fc16.noarch
aeolus-all-0.11.0-0.20120726160007git373f3dc.fc16.noarch
aeolus-configure-2.7.0-0.20120726120022gitee0ff5c.fc16.noarch
aeolus-conductor-daemons-0.11.0-0.20120726160007git373f3dc.fc16.noarch

Steps to Reproduce:
1. Install aeolus conductor on F16 
2. Log in as 'admin'
3. Create a new 'Openstack' provider - Adding the Openstack API_ENTRYPOINT
4. Click 'Save Provider'

Actual results:

See error as described above

Expected results:

Provider should be added

Additional info:

The f16 test machine has updates-testing repo enabled (during install)
Comment 1 Jozef Zigmund 2012-09-10 11:17:20 EDT
The issue is fixed in recent master branch (tested on commit # 180f182d7e91fda3982b2f0386b043c254144086) and also on 1.1 branch (tested on commit # 65c26fdae27e99d0dfb3ab5f6553321ceacd95a6). Please verify it.
Comment 3 Ronelle Landy 2012-09-20 18:48:27 EDT
Tested rpms:

>> rpm -qa |grep aeolus
aeolus-configure-2.8.6-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-conductor-0.13.8-1.el6cf.noarch
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch
aeolus-all-0.13.8-1.el6cf.noarch

Now adding a new Openstack provider gives a different error:

***********

Warnings

    Cannot add the Cloud Resource Provider.

Errors

    1 error prohibited this Cloud Resource Provider from being saved
    Cloud Resource Provider URL Must be a valid provider uri

**********

See the attached screenshot.

I entered : https://region-a.geo-1.identity.hpcloudsvc.com:35357/v2.0/ as the Openstack API_ENTRYPOINT ... which should be vaild (it works with Deltacloud).

Since Openstack will not be a supported provider for 1.1, I am moving this BZ back to 'Assigned' so dev can decide the correct status.
Comment 4 Ronelle Landy 2012-09-20 18:48:57 EDT
Created attachment 615167 [details]
Valid URI error
Comment 5 Mike Orazi 2012-09-21 11:20:10 EDT
This appears to only apply to openstack which isn't supported in 1.1.  Moving to 2.0 for consideration at that point.
Comment 6 RHEL Product and Program Management 2012-09-21 11:36:13 EDT
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.