Bug 843856 - [RHEVM] [backend] [Host Networking] DC/CL 3.0 cannot change static IP for VLAN
[RHEVM] [backend] [Host Networking] DC/CL 3.0 cannot change static IP for VLAN
Status: CLOSED DUPLICATE of bug 842734
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike Kolesnik
Martin Pavlik
network
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-27 10:58 EDT by Martin Pavlik
Modified: 2016-02-10 14:55 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-15 04:48:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot 1 (235.90 KB, image/png)
2012-07-27 10:58 EDT, Martin Pavlik
no flags Details

  None (edit)
Description Martin Pavlik 2012-07-27 10:58:37 EDT
Created attachment 600807 [details]
screenshot 1

Description of problem:
cannot change static IP for VLAN on host which is in DC/CL 3.0

Following error appears: (screenshot 1)
	
Error:

dell-r210ii-05.rhev.lab.eng.brq.redhat.com:

    Previous network name is required.


Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Manager Version: '3.1.0-9.el6ev' 

How reproducible:
100%

Steps to Reproduce:
1.Create 2 VLAN tagged networks in DC/CL 3.0
2.Assign VLANs to the same host interface (when assigning define static IPs)
3.Select interface from step 2 by !!! checking the checkbox on the LEFT side !!! -> click Add/Edit -> modify static IP for one VLAN -> click OK (see screenshot 1)
  
Actual results:
error appears

Expected results:
IP should get changed for selected VLAN

Additional info:
if checkbox on the right side side is used to seclect VLAN, it is possible to change IP


2012-07-27 16:34:15,581 WARN  [org.ovirt.engine.core.bll.UpdateNetworkToVdsInterfaceCommand] (ajp-/127.0.0.1:8009-1) [4448c279] CanDoAction of action UpdateNetworkToVdsInterface failed. Reasons:NETWROK_OLD_NETWORK_NOT_SPECIFIED
Comment 3 lpeer 2012-08-15 04:48:29 EDT
The problem described in this bug is that by choosing a nic you should not be able to edit vlan network parameters and this was fixed in bug 842734

*** This bug has been marked as a duplicate of bug 842734 ***

Note You need to log in before you can comment on or make changes to this bug.