Bug 84386 - rpm --rebuilddb fails with db4 error
rpm --rebuilddb fails with db4 error
Status: CLOSED DUPLICATE of bug 83281
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2003-02-15 07:12 EST by Daniel Resare
Modified: 2007-04-18 12:51 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:51:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Daniel Resare 2003-02-15 07:12:01 EST
Description of problem:

When I try to rebuild my rpm database with the 'rpm --rebuilddb' command
on my phoebe2 + selected rawhide pieces it always fails with the following

[root@c-6c1a72d5 RPMS]# LANG=C rpm --rebuilddb
error: db4 error(16) from dbenv->remove: Device or resource busy

Version-Release number of selected component (if applicable):

How reproducible:
have tried 5 times with different db4 and rpm versions from rawhide

Steps to Reproduce:
1. run 'rpm --rebuilddb' as root
Actual results:
[root@c-6c1a72d5 RPMS]# LANG=C rpm --rebuilddb
error: db4 error(16) from dbenv->remove: Device or resource busy

Expected results:

Additional info:

The rpm database seems to work with the generated database regardless of the error.
Comment 1 Michael Young 2003-02-15 09:55:03 EST
Duplicate of Bug 83281
Comment 2 Daniel Resare 2003-02-16 14:09:49 EST

*** This bug has been marked as a duplicate of 83281 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:51:49 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.