Bug 843907 - subscription-manager repos --enable AND --disable options can't be used together
subscription-manager repos --enable AND --disable options can't be used together
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity medium
: rc
: 5.9
Assigned To: William Poteat
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-07-27 12:05 EDT by John Sefler
Modified: 2013-01-07 22:57 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:57:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-07-27 12:05:38 EDT
Description of problem:
When I specify both the --enable AND --disable options in the same subscription-manager repos call with valid repoIds, the --disable option is ignored.

Version-Release number of selected component (if applicable):
[root@jsefler-rhel59 ~]# rpm -q subscription-manager
subscription-manager-1.0.11-1.git.2.d2c02ce.el5

How reproducible:


Steps to Reproduce:
1. register and subscribe to something that provides content
# subscription-manager repos --list | grep "Repo Id"
Repo Id:              	awesomeos
Repo Id:              	awesomeos-x86_64
Repo Id:              	awesomeos-ppc
Repo Id:              	always-enabled-content
Repo Id:              	never-enabled-content
Repo Id:              	awesomeos-ppc64
Repo Id:              	awesomeos-s390x
Repo Id:              	awesomeos-ia64
Repo Id:              	awesomeos-i686
# subscription-manager repos --enable=awesomeos
Repo awesomeos is enabled for this system.
# subscription-manager repos --disable=awesomeos-x86_64
Repo awesomeos-x86_64 is disabled for this system.
# subscription-manager repos --enable=awesomeos --disable=awesomeos-x86_64
Repo awesomeos is enabled for this system.
# 

Actual results:
Repo awesomeos is enabled for this system.

Expected results:
Repo awesomeos is enabled for this system.
Repo awesomeos-x86_64 is disabled for this system.

Additional info:
Comment 1 RHEL Product and Program Management 2012-07-27 12:18:48 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 John Sefler 2012-07-27 12:24:22 EDT
What I really want is a fix for Bug 843915 which will implicitly fix this bug too.
Comment 3 William Poteat 2012-08-06 09:53:39 EDT
master commit: 9f524fd79a924a57d6c1ec31f30480601fd77160
Comment 5 Shwetha Kallesh 2012-08-07 02:09:21 EDT
Marking verified!!

RPM used:
[root@dhcp201-115 tmp]# rpm -qa |grep subscription-manager
subscription-manager-migration-data-1.11.2.2-1.git.2.c3c8e22.el5
subscription-manager-firstboot-1.0.12-1.git.36.cb30843.el5
subscription-manager-migration-1.0.12-1.git.36.cb30843.el5
subscription-manager-1.0.12-1.git.36.cb30843.el5
subscription-manager-gui-1.0.12-1.git.36.cb30843.el5


[root@dhcp201-115 ~]# subscription-manager repos --enable=awesomeos --disable=awesomeos-x86_64
Repo awesomeos is enabled for this system.
Repo awesomeos-x86_64 is disabled for this system.
Comment 7 errata-xmlrpc 2013-01-07 22:57:58 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.