Bug 843914 - [TEXT] improve error message when user tries to downgrade data center compatibility level
[TEXT] improve error message when user tries to downgrade data center compati...
Status: CLOSED UPSTREAM
Product: oVirt
Classification: Community
Component: ovirt-engine-webadmin (Show other bugs)
3.1 RC
x86_64 Linux
unspecified Severity unspecified
: ---
: 3.3.4
Assigned To: Alissa
storage
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-27 12:21 EDT by Cybertimber2011
Modified: 2016-02-10 11:29 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-04 10:01:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 12678 None None None Never

  None (edit)
Description Cybertimber2011 2012-07-27 12:21:36 EDT
Description of problem:
Cannot change the Data Center compatibility version from 3.1.
Changing to 3.0 or 2.2 results in an error.

Version-Release number of selected component (if applicable):
ovirt-engine-webadmin-portal-3.1.0-1.fc17.noarch

How reproducible:
Always?

Steps to Reproduce:
1. Login to Admin
2. Click Data Centers
3. Click Default
4. Click Edit
5. Change compatibility version to 3.0 or 2.2
6. Click ok twice
  
Actual results:
Error: Cannot edit Repository. Compatibilty version is invalid, previous value restored.

Expected results:
Change of compatibility version

Additional info:
If this is expected (can't support 2.2/3.0) can we remove the 2.2/3.0 options?
Comment 1 Cybertimber2011 2012-07-27 12:26:05 EDT
Additional testing:
You can however create a new datacenter set to 2.2 and 3.0.
I created data center "legacy2" set to 2.2 and it worked, and I was able to upgrade it to 3.0. I cannot move it back to 2.2 without the above erorr.

I created data center "legacy3" set to 3.0 adn it worked, and I was able to upgrade it to 3.1. But once it is on 3.1, it cannot be changed to 3.0 or 2.2 without the above error.

I'm wondering if this is a bug, or if it's intended... eg, you can't move compatibility down a level.
Comment 2 Itamar Heim 2012-07-28 01:02:52 EDT
indeed - not a bug - you cannot downgrade a DC level.
error message could be improved though...
changing to a TEXT bug.

care to try and send a patch for a better message?
Comment 3 Cybertimber2011 2012-07-31 18:30:58 EDT
I'd be glad to try. I'm guessing I'd have to look at the source for that. Mind meeting me in IRC some time so I can learn how to do that and make the change?
Comment 4 Itamar Heim 2012-08-01 02:51:15 EDT
irc is sometime harder for me than emails.
just grep for the message you get (or part of it)

usually messages are in these files:
backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dal/VdcBllMessages.java
backend/manager/modules/dal/src/main/resources/bundles/AppErrors.properties
frontend/webadmin/modules/frontend/src/main/java/org/ovirt/engine/ui/frontend/AppErrors.java
frontend/webadmin/modules/userportal-gwtp/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
frontend/webadmin/modules/webadmin/src/main/resources/org/ovirt/engine/ui/frontend/AppErrors.properties
Comment 5 Alissa 2013-03-10 13:57:28 EDT
I submitted a patch with improved text of error message as proposed here, thus the bug was marked as closed (fixed)

Note You need to log in before you can comment on or make changes to this bug.