Bug 843915 - multiple specifications of --enable AND --disable options are ignored by subscription-manager repos
multiple specifications of --enable AND --disable options are ignored by subs...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity medium
: rc
: 5.9
Assigned To: William Poteat
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-07-27 12:21 EDT by John Sefler
Modified: 2013-01-07 22:58 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:58:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-07-27 12:21:39 EDT
Description of problem:
Both the subscription-manager subscribe --pool and register --activationkey allow the user to specify multiple option values.  It would also be useful to support this same functionality with subscription-manager repos --enable and --disable options.

Version-Release number of selected component (if applicable):
[root@jsefler-rhel59 ~]# rpm -q subscription-manager
subscription-manager-1.0.11-1.git.2.d2c02ce.el5


How reproducible:


Steps to Reproduce:
1. register and subscribe, then...
[root@jsefler-rhel59 ~]# subscription-manager repos --list | grep "Repo Id"
Repo Id:              	awesomeos
Repo Id:              	awesomeos-x86_64
Repo Id:              	awesomeos-ppc
Repo Id:              	always-enabled-content
Repo Id:              	never-enabled-content
Repo Id:              	awesomeos-ppc64
Repo Id:              	awesomeos-s390x
Repo Id:              	awesomeos-ia64
Repo Id:              	awesomeos-i686
[root@jsefler-rhel59 ~]# subscription-manager repos --enable=awesomeos --disable=awesomeos-x86_64 --enable=awesomeos-ppc --disable=always-enabled-content --enable=never-enabled-content --disable=awesomeos-ppc64 --enable=awesomeos-s390x --enable=awesomeos-ia64 --enable=awesomeos-i686
Repo awesomeos-i686 is enabled for this system.
[root@jsefler-rhel59 ~]# 

  
Actual results:
Repo awesomeos-i686 is enabled for this system.

Expected results:
Repo awesomeos is enabled for this system.
Repo awesomeos-x86_64 is disabled for this system.
Repo awesomeos-ppc is enabled for this system.
Repo always-enabled-content is disabled for this system.
Repo never-enabled-content is enabled for this system.
Repo awesomeos-ppc64 is disabled for this system.
Repo awesomeos-s390x is enabled for this system.
Repo awesomeos-ia64 is enabled for this system.
Repo awesomeos-i686 is enabled for this system.


Additional info:
Comment 1 RHEL Product and Program Management 2012-07-27 12:38:23 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 John Sefler 2012-07-28 10:28:51 EDT
Additional Info:
If an invalid repo id is encountered in the option values, then the expected results should log it and continue processing the other --enable/--disable repoid options.  For example...

# subscription-manager repos --enable=good --enable=bad --disable=better 
Repo good is enabled for this system.
Repo bad is invalid.  Use --list option to see valid repos.
Repo better is disabled for this system.
Comment 3 William Poteat 2012-08-03 13:26:18 EDT
master commit: 9f524fd79a924a57d6c1ec31f30480601fd77160
Comment 5 Shwetha Kallesh 2012-08-07 02:35:25 EDT
Verified!

RPM used:
[root@dhcp201-115 ~]# rpm -qa | grep subscription-manager
subscription-manager-migration-data-1.11.2.2-1.git.2.c3c8e22.el5
subscription-manager-firstboot-1.0.12-1.git.36.cb30843.el5
subscription-manager-migration-1.0.12-1.git.36.cb30843.el5
subscription-manager-1.0.12-1.git.36.cb30843.el5
subscription-manager-gui-1.0.12-1.git.36.cb30843.el5


[root@dhcp201-115 ~]# subscription-manager repos --enable=awesomeos --disable=awesomeos-x86_64 --disable=always-enabled-content --enable=never-enabled-content
Repo awesomeos is enabled for this system.
Repo never-enabled-content is enabled for this system.
Repo awesomeos-x86_64 is disabled for this system.
Repo always-enabled-content is disabled for this system.
Comment 7 errata-xmlrpc 2013-01-07 22:58:00 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.