Bug 844022 - F17 overheats Mac Pro
F17 overheats Mac Pro
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-27 19:43 EDT by Andrew
Modified: 2013-08-01 02:53 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 02:53:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew 2012-07-27 19:43:54 EDT
Description of problem:

Gnome-shell running in background is running all 8 cpu cores constantly at 33%. Core temperatures rise until programs start crashing then whole computer locks up and reboot is required, this only take 20 mins.

This is a brand new clean install of F17 on a 2009 Mac Pro. We didn't have this problem with F16.

It was a "textbook" installation. Everything appeared to install perfectly without any problems. Did the updates including the 3.4.6 kernel which boots fine on the Mac now, thank you for that.

gkrellm shows the cpu's running at 33% and shows the temperatures. I used System Monitor to see what was running, Xorg is using one cpu at 0.5%, Gnome-shell is using all cpu's at 33%, everything else is at idle.

Version-Release number of selected component (if applicable):

?

How reproducible:

I imagine a repeat of the install would give the same result but would like to know what to watch for before doing another 1.5 Gb update.

Steps to Reproduce:

1. Install Fedora 17 on a Mac Pro (using nogpt)

2. Do the updates

3. install gkrellm so you can see what's happening.
  
Actual results:

Overheat and crashing

Expected results:

 sweet running system like we had with F16

Additional info:

Will try another clean install without the updates after I've heard back from you, will wait until then just in case you want some of the log files for trouble shooting.

Cheers,

Andrew.
Comment 1 Andrew 2012-07-27 23:43:52 EDT
Sorry but the bloke that owns the Mac wanted to be able to use his computer again.

I did another clean install of F17 using the install DVD, nothing fancy, just the standard graphical desktop install with nothing extra. After that I installed gkrellm and ran it. All 8 cpu's are running constantly at around 33% capacity, temperatures in the 80's and climbing, and I'm talking Celsius.

Am halfway through reinstalling F16 for the fella now but I did save a lot of his files for you, including:

the anaconda log files
all of the users hidden files
/boot
/etc
/var/log
Various other bits and peices

tried to save the entire lot but ran into trouble doing that, also they're saved on a fat32 file system so all permissions, ownerships and symlinks are gone.

Cheers,

Andrew.
Comment 2 Andrew 2012-07-28 04:14:23 EDT
Follow Up:

I just reinstalled F16 on that Mac Pro then loaded gkrellm, only activity was tiny spikes on different cpu's, temperature hanging around 37 degrees celsius which is pretty good considering my room temperature is around 34 degrees. - I live in the tropics.

Did all the updates from a copy of your repo dated 18 March, 2012. I bought it from Osdisc, love those guys!. No temperature concerns or unwarranted activity at all. Now running kernel-3.2.9-2.

Went back in there before ever setting up an internet connection, using Yumex, sorted by groups, ticked every category box (except languages) to install the default programs from each category, he's a new linux user and wants to play with stuff.

Added ATrpms, installed libdvdcss, lame, vlc, clementine, made sure he had the others as in Digikam, Gimp and Grip. Sorry but amarok sucks balls.

Right now he's ripping a dvd to mkv, listening to music on clementine and using digikam and gimp to touch up a few photos. Biggest spike on one cpu I've seen is around 50% and they all seem to be taking it in turns. Temperatures are hanging around the 39 degree mark. Absolutely perfect!

This Mac Pro is *almost* stock standard.

After trying Fedora for about a week the bloke asked me to remove Mac osX fromthe mac while he tried to forget how much money he paid for it. It's now dual boot Fedora/WinXP on a 600Gb drive. Two other 1.5 Tb drives are formatted fat32 so anything can access them.

The only other break from the stock system is it's graphics card died and I had a cheaparse old GT520 hanging around and shoved that in, it works! In F16 I have to load the proprietary driver to get Gnome3, in F17 I don't.

Cheers,

Andrew.
Comment 3 Fedora End Of Life 2013-07-03 21:53:29 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 4 Fedora End Of Life 2013-08-01 02:53:17 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.