Bug 844087 - virt-sysprep segfault during libguestfs build
virt-sysprep segfault during libguestfs build
Status: CLOSED NOTABUG
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-28 13:38 EDT by Richard W.M. Jones
Modified: 2012-07-28 16:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-28 16:30:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2012-07-28 13:38:56 EDT
Description of problem:

During libguestfs make in Rawhide:

../run ./virt-sysprep --dump-pod-options > sysprep-extra-options.pod-t
/bin/sh: line 1: 29454 Segmentation fault      (core dumped) ../run ./virt-sysprep --dump-pod-options > sysprep-extra-options.pod-t
make: *** [sysprep-extra-options.pod] Error 139

The stack trace is:

#0  __textdomain (domainname=0x3 <Address 0x3 out of bounds>)
    at textdomain.c:95
#1  0x00000000004cb81b in gettextStubCompat_textdomain ()
#2  0x000000000047976c in camlGettextStub__realize_1117 ()
#3  0x00002acec4e3cff8 in ?? ()
#4  0x00000000007735e0 in camlGettextStub__7 ()
#5  0x00002acec4f97ca8 in ?? ()
#6  0x000000000047c4bb in camlGettext__get_global_t$27_1118 ()
#7  0x00002acec4e3d058 in ?? ()
#8  0x000000000047b268 in camlGettext__f__1206 ()
#9  0x00002acec4eaf640 in ?? ()
#10 0x0000000000775e30 in camlGettext__69 ()
#11 0x00000000007735c8 in camlGettextStub__6 ()
#12 0x000000000047bbaf in camlGettext__fun_1356 ()
#13 0x00002acec4eaf4c0 in ?? ()
#14 0x000000000049e7f4 in camlCamlinternalOO__resize_1130 ()
#15 0x00002acec4e3d220 in ?? ()
#16 0x00002acec4eaf408 in ?? ()
#17 0x000000000047c19d in camlGettext__fun_1503 ()
#18 0x0000000000000028 in ?? ()
#19 0x0000000000454365 in camlSysprep_gettext__entry ()
#20 0x00000000004450c9 in caml_program ()
#21 0x00000000004e34e6 in caml_start_program ()
#22 0x00000000004d05b9 in caml_main ()
#23 0x0000000000444d3c in main ()

Version-Release number of selected component (if applicable):

libguestfs 1.19.26

ocaml-gettext bug?
Comment 1 Richard W.M. Jones 2012-07-28 16:30:22 EDT
Think this was just because ocaml-gettext hadn't been
recompiled against OCaml 4.00.0, which has now been done.
In any case, it's fixed itself after recompiling everything.

Note You need to log in before you can comment on or make changes to this bug.