This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 844156 - [abrt] libreoffice-core-3.5.5.3-2.fc17: Process /usr/lib/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
[abrt] libreoffice-core-3.5.5.3-2.fc17: Process /usr/lib/libreoffice/program/...
Status: CLOSED DUPLICATE of bug 832603
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:87613e89d5c17a1a65ed905f068...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-29 08:56 EDT by cstent
Modified: 2012-07-31 03:31 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-31 03:31:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: core_backtrace (5.67 KB, text/plain)
2012-07-29 08:56 EDT, cstent
no flags Details
File: backtrace (66.15 KB, text/plain)
2012-07-29 08:56 EDT, cstent
no flags Details
File: maps (67.85 KB, text/plain)
2012-07-29 08:56 EDT, cstent
no flags Details
File: dso_list (24.28 KB, text/plain)
2012-07-29 08:56 EDT, cstent
no flags Details

  None (edit)
Description cstent 2012-07-29 08:56:10 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/lib/libreoffice/program/soffice.bin --writer file:///home/cstent/Dropbox/miscellaneous/Guides/Installation%20Instructions%20Fedora.odt --splash-pipe=6
comment:        I just tried to close an open odp presentation document and it crashed.
crash_function: std::list<Link, std::allocator<Link> >::remove
executable:     /usr/lib/libreoffice/program/soffice.bin
kernel:         3.4.6-2.fc17.i686
pid:            3422
pwd:            /home/cstent
time:           Sun 29 Jul 2012 15:10:23 EEST
uid:            1000
username:       cstent
xsession_errors: 

backtrace:      Text file, 67739 bytes
core_backtrace: Text file, 5802 bytes
dso_list:       Text file, 24861 bytes
maps:           Text file, 69476 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/cstent/2

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=Newton
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GIO_LAUNCHED_DESKTOP_FILE_PID=3408
:GPG_AGENT_INFO=/run/user/cstent/keyring-9nreVP/gpg:0:1
:SHELL=/bin/bash
:TERM=dumb
:DESKTOP_STARTUP_ID=nautilus-2385-Newton-libreoffice-4_TIME6832539
:HISTSIZE=1000
:XDG_SESSION_COOKIE=b363f883fdc397b92727b2060000000c-1343540264.331589-198843577
:GJS_DEBUG_OUTPUT=stderr
:OLDPWD=/usr/lib/libreoffice/program
:QTDIR=/usr/lib/qt-3.3
:GNOME_KEYRING_CONTROL=/run/user/cstent/keyring-9nreVP
:QTINC=/usr/lib/qt-3.3/include
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:QT_GRAPHICSSYSTEM_CHECKED=1
:IMSETTINGS_MODULE=none
:USER=cstent
:SSH_AUTH_SOCK=/run/user/cstent/keyring-9nreVP/ssh
:USERNAME=cstent
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1155,unix/unix:/tmp/.ICE-unix/1155
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/libreoffice-writer.desktop
:MAIL=/var/spool/mail/cstent
:PATH=/usr/lib/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/cstent/.local/bin:/home/cstent/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/cstent
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=1153
:LANG=en_GB.utf8
:GDM_LANG=en_GB.utf8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/cstent
:SHLVL=1
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SAL_ENABLE_FILE_LOCKING=1
:LOGNAME=cstent
:QTLIB=/usr/lib/qt-3.3/lib
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-eM2w9DfH98,guid=55212315d08c7bbe54815d56000000ae
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/cstent
:DISPLAY=:0.0
:XAUTHORITY=/var/run/gdm/auth-for-cstent-VqeHIY/database
:LD_LIBRARY_PATH=/usr/java/jre1.6.0_30/lib/i386/client:/usr/java/jre1.6.0_30/lib/i386/server:/usr/java/jre1.6.0_30/lib/i386/native_threads:/usr/java/jre1.6.0_30/lib/i386

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 23609                processes 
:Max open files            4096                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       23609                23609                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/home/cstent/.xsession-errors
:pos:	70943
:flags:	02002
:2:/home/cstent/.xsession-errors
:pos:	70943
:flags:	02002
:3:socket:[439849]
:pos:	0
:flags:	02004002
:4:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:5:pipe:[439091]
:pos:	0
:flags:	00
:6:pipe:[439091]
:pos:	0
:flags:	01
:7:socket:[439856]
:pos:	0
:flags:	02000002
:8:socket:[439858]
:pos:	0
:flags:	02004002

smolt_data:
:
:
:General
:=================================
:UUID: 37c5309b-5a75-42ac-a04e-5c4108ca77f5
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_GB.utf8
:Platform: i686
:BogoMIPS: 3736.28
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM)2 CPU          6300  @ 1.86GHz
:CPU Stepping: 6
:CPU Family: 6
:CPU Model Num: 15
:Number of CPUs: 2
:CPU Speed: 1862
:System Memory: 2967
:System Swap: 5023
:Vendor: System manufacturer
:System: System Product Name System Version
:Form factor: Desktop
:Kernel: 3.4.6-2.fc17.i686
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:10656:4163:33258) pci, None, HOST/PCI, P5B
:(32902:10657:32902:10109) pci, pcieport, PCI/PCI, 82P965/G965 PCI Express Root Port
:(32902:10302:4163:33260) pci, None, SERIAL, P5B
:(32902:10272:4163:33260) pci, ata_piix, STORAGE, 82801H (ICH8 Family) 4 port SATA IDE Controller
:(32902:10256:4163:33260) pci, None, PCI/ISA, P5B
:(32902:10277:4163:33260) pci, ata_piix, STORAGE, 82801H (ICH8 Family) 2 port SATA IDE Controller
:(6523:9059:4163:33252) pci, ahci, STORAGE, P5B [JMB363]
:(6523:9059:4163:33252) pci, pata_jmicron, STORAGE, P5B [JMB363]
:(32902:10289:4163:33260) pci, uhci_hcd, USB, P5B
:(32902:9294:4163:33260) pci, None, PCI/PCI, 82801 PCI Bridge
:(32902:10290:4163:33260) pci, uhci_hcd, USB, P5B
:(32902:10294:4163:33260) pci, ehci_hcd, USB, P5B
:(32902:10298:4163:33260) pci, ehci_hcd, USB, P5B
:(4332:33128:4163:33194) pci, r8169, ETHERNET, P5B
:(32902:10309:4163:33260) pci, pcieport, PCI/PCI, 82801H (ICH8 Family) PCI Express Port 4
:(32902:10303:4163:33260) pci, pcieport, PCI/PCI, 82801H (ICH8 Family) PCI Express Port 1
:(32902:10311:4163:33260) pci, pcieport, PCI/PCI, 82801H (ICH8 Family) PCI Express Port 5
:(32902:10315:4163:33260) pci, snd_hda_intel, MULTIMEDIA, P5B
:(32902:10292:4163:33260) pci, uhci_hcd, USB, P5B
:(32902:10288:4163:33260) pci, uhci_hcd, USB, P5B
:(4318:914:4163:33300) pci, nouveau, VIDEO, G73 [GeForce 7600 GS]
:(6164:12384:4163:34018) pci, rt2800pci, NETWORK, RT3060 Wireless 802.11n 1T/1R
:(32902:10293:4163:33260) pci, uhci_hcd, USB, P5B
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_newton-lv_root / ext4 4096 4096 13091009 10101114 9970082 3276800 2977002 2977002
:/dev/sdc1 WITHHELD ext3 4096 4096 19216857 1003962 27110 4890624 4871828 4871828
:/dev/sda3 /boot ext4 1024 1024 508644 408578 382978 128016 127750 127750
:/dev/mapper/vg_newton-lv_home /home ext4 4096 4096 53311269 47676423 45007470 13344768 13274378 13274378
:

var_log_messages:
:Jul 29 15:10:23 Newton kernel: [23732.733133] soffice.bin[3422]: segfault at 4f ip 4c6f186b sp bfc80cc0 error 4 in libvcllo.so[4c62a000+496000]
:Jul 29 15:10:26 Newton abrt[5802]: Saved core dump of pid 3422 (/usr/lib/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2012-07-29-15:10:23-3422 (121753600 bytes)
Comment 1 cstent 2012-07-29 08:56:19 EDT
Created attachment 601025 [details]
File: core_backtrace
Comment 2 cstent 2012-07-29 08:56:23 EDT
Created attachment 601026 [details]
File: backtrace
Comment 3 cstent 2012-07-29 08:56:28 EDT
Created attachment 601027 [details]
File: maps
Comment 4 cstent 2012-07-29 08:56:44 EDT
Created attachment 601028 [details]
File: dso_list
Comment 5 Caolan McNamara 2012-07-30 13:41:25 EDT
This is possibly due to that c++11/c++03 accidental incompatibility, so if we turn off c++0x mode in F-17 we probably solve this problem
Comment 6 David Tardon 2012-07-31 03:31:04 EDT

*** This bug has been marked as a duplicate of bug 832603 ***

Note You need to log in before you can comment on or make changes to this bug.