Bug 844159 - Ovirt Rest API - empty 'from' parameter in search causes the error
Ovirt Rest API - empty 'from' parameter in search causes the error
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-restapi (Show other bugs)
3.1.0
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Michael Pasternak
Elena
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-29 08:59 EDT by Elena
Modified: 2016-02-10 14:38 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-02 05:22:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elena 2012-07-29 08:59:28 EDT
api/events;from=?search=istein%20type%3D852

engine.log:
2012-07-29 12:23:51,436 ERROR [org.ovirt.engine.api.restapi.resource.AbstractBackendCollectionResource] (http-/0.0.0.0:8080-60) Unwrapping of 'from' search parameter failed.: java.lang.NumberFormatException: For input string: ""
 at java.lang.NumberFormatException.forInputString(NumberFormatException.java:65)
Comment 1 Oded Ramraz 2012-07-30 02:37:48 EDT
This issue is not a low severity since it is flooding the logs and makes debug process harder.
Comment 2 Michael Pasternak 2012-08-02 05:22:18 EDT
by design, the issue that causing log flood is absence of valid int 
in /from parameter, please fix your tests

Note You need to log in before you can comment on or make changes to this bug.