Bug 844160 - PulseAudio ALSA Plugin breaks pSX
PulseAudio ALSA Plugin breaks pSX
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pulseaudio (Show other bugs)
6.3
All Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Wim Taymans
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-29 09:01 EDT by Martyn Hare (WarOfTheNerd)
Modified: 2016-08-22 11:10 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 842055
Environment:
Last Closed: 2016-08-22 11:10:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martyn Hare (WarOfTheNerd) 2012-07-29 09:01:44 EDT
+++ This bug was initially created as a clone of Bug #842055 +++

PulseAudio ALSA Plugin is not fully compatible with the way pSX uses ALSA.  PulseAudio should not be breaking ALSA applications, even non-free ones.

To reproduce PA bug:

Run pSX with a selected BIOS.  

pSX can be found here:  http://psxemulator.gazaxian.com/

An unofficial package created for Fedora may be found here:  http://repo.warofthenerd.net/f17/i686/pSX-1.13-2.fc17.i686.rpm

Expected Result:

pSX loads up and sound outputs.  

This is the case with ALSA without PulseAudio interfering, or if you use ALSA with dmix and PA using dmix.

Actual Result:

pSX crashes before a GUI window can be fully displayed, due to ALSA-related errors.

Console Output:

Gtk-Message: Failed to load module "pk-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"
[src/linux/sound.cpp, line 215]: 'snd_pcm_hw_params_set_access(pcm_handle,hwparams,SND_PCM_ACCESS_MMAP_INTERLEAVED)' returned 'Invalid argument'
pad=0
Segmentation fault (core dumped)
Comment 2 RHEL Product and Program Management 2012-09-07 01:33:15 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 3 Wim Taymans 2016-08-22 11:10:07 EDT
From http://www.fedoraforum.org/forum/showthread.php?t=296750

Try pcsxr, it works here.

"pSX is very outdated and compatibility with games isn't very good. The only thing going for it is that it has low system requirements. The source code was never released unfortunately, so it cannot be updated.

Note You need to log in before you can comment on or make changes to this bug.