Bug 844168 - [admin-portal] direct lun: getDeviceList is not sent for FC storage type
[admin-portal] direct lun: getDeviceList is not sent for FC storage type
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
urgent Severity urgent
: ---
: 3.1.0
Assigned To: Daniel Erez
Gadi Ickowicz
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-29 10:09 EDT by Gadi Ickowicz
Modified: 2016-02-10 11:57 EST (History)
11 users (show)

See Also:
Fixed In Version: SI13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:04:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gadi Ickowicz 2012-07-29 10:09:51 EDT
Description of problem:
new disk dialogue, choose external disk, getDeviceList should be sent to discover
all current luns host is familiar with, this doesn't happen when changing between storage types. it only happens after discovery. 
please implement the same logic as in new storage domain flow (for block devices).

Steps to Reproduce:
1. Select Add disk
2. External Disk
3. Change storage type and grep getDeviceList on vdsm.log.
Comment 2 Itamar Heim 2012-07-29 11:45:16 EDT
if this is not a regression from 3.0, not sure if critical to fix considering all other open issues. not sure why its set as a testblocker?
Comment 3 Haim 2012-07-29 11:48:58 EDT
(In reply to comment #2)
> if this is not a regression from 3.0, not sure if critical to fix
> considering all other open issues. not sure why its set as a testblocker?
well, its a test blocker since it blocks us from testing direct lun over FC (its a part of our test plan).
currently, we cannot test FC, so it's pretty crucial we will fix it (considering its easy to fix).
Comment 4 Daniel Erez 2012-07-29 14:50:32 EDT
DirectLUN over FC can still be tested:
by choosing 'Fibre Channel' as 'Stroage Type' before selecting a DC/Host
(getDeviceList is called on Host change).
Comment 5 Daniel Erez 2012-07-31 07:20:13 EDT
commit c888313e9d9419b39b345de711b7437d7ec1eba5
Comment 7 Haim 2012-08-12 09:15:19 EDT
verified on si13.2 - getDeviceList is now send on all states (when changing hosts and moving between iSCSI and FC types).

Note You need to log in before you can comment on or make changes to this bug.