Bug 844230 - dracut-pre-pivot[212]: //lib/dracut/hooks/pre-privot/90plymouth-newroot.sh: line 5: [: too many arguments
dracut-pre-pivot[212]: //lib/dracut/hooks/pre-privot/90plymouth-newroot.sh: l...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
: 844229 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-30 00:37 EDT by Jens Petersen
Modified: 2013-02-05 05:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-29 10:27:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2012-07-30 00:37:37 EDT
Description of problem:
Rawhide boot currently fails to complete (eventually running into some lvm
systemd lvm storage subsystem errors).

I noticed the error in the Summary while booting:

"""
[ OK ] Reached target Basic System
dracut-pre-pivot[212]: //lib/dracut/hooks/pre-privot/90plymouth-newroot.sh: line 5: [: too many arguments

Welcome to Fedora 18 (Rawhide)!

[ OK ] Reached target Login Prompts
:
[ OK ] Stopped Journal Service.
       Starting Journal Service...
[FAIL] Failed to start Journal Service.
:
"""

I think the lvm storage errors are unrelated.

Version-Release number of selected component (if applicable):
dracut-022-63.git20120727.fc18

How reproducible:
every time

Steps to Reproduce:
1. install rawhide
2. boot rawhide install
  
Actual results:
above error from 

Expected results:
no error

Additional info:
Booting without rhgb still got the same error.
Comment 1 Harald Hoyer 2012-07-30 07:40:53 EDT
*** Bug 844229 has been marked as a duplicate of this bug. ***
Comment 2 Garrett Mitchener 2013-02-04 11:56:34 EST
I'm not sure if this is the same problem or not: I got heaps of "Failed to start Journal Service" errors on a rawhide virtual machine after I added selinux=0 on the kernel command line at boot time, then tried to boot without that.  I solved part of the problem by doing

touch /.autorelabel

as root and rebooting (see  http://fedoraproject.org/wiki/SELinux/ManagingFileContext) then running

fixfiles relabel

as root from a non-graphical terminal.  That got rid of a lot of the boot problems, but now I can't get a graphical login dialog, just a blank black X windows screen, even though

systemctl status gdm

shows that Gnome display manager claims to be running normally.
Comment 3 Harald Hoyer 2013-02-05 05:11:30 EST
(In reply to comment #2)
> I'm not sure if this is the same problem or not: I got heaps of "Failed to
> start Journal Service" errors on a rawhide virtual machine after I added
> selinux=0 on the kernel command line at boot time, then tried to boot
> without that.  I solved part of the problem by doing
> 
> touch /.autorelabel
> 
> as root and rebooting (see 
> http://fedoraproject.org/wiki/SELinux/ManagingFileContext) then running
> 
> fixfiles relabel
> 
> as root from a non-graphical terminal.  That got rid of a lot of the boot
> problems, but now I can't get a graphical login dialog, just a blank black X
> windows screen, even though
> 
> systemctl status gdm
> 
> shows that Gnome display manager claims to be running normally.

This would be a bug for initscripts, because it is supposed to touch .autorelabel and do the fixfiles with:

/lib/systemd/system/fedora-autorelabel.service
/lib/systemd/system/fedora-autorelabel-mark.service

Do you have these service files? And are you sure, you didn't mask them?

Note You need to log in before you can comment on or make changes to this bug.